Put URL failing -- HTTP header problems?

Sivakatirswami katir at hindu.org
Tue May 9 18:52:49 EDT 2006


Other URL's always work just fine

put url "http://www.runrev.com"

(and many others, all just work fine)

So if the proxy settings were wrong any request should fail...

it is only to this site

put url "http://www.pacsoa.org.au/palms/Acanthophoenix/"

Then, sometimes it *does* work... it is as if DNS is failing  
randomly, but only for this one site and only in Revolution (same  
behavior in 2.6 btw...) because the errors coming back are from  
various other servers...

another anamoly:

if I drop the end of the URL and don't supply a slash or "index.html"  
just this:

http://www.pacsoa.org.au/palms/Acanthophoenix

Then is seems to work more often than not. But, it *always* works in  
firefox so there has

Mysterious... I'm trying to write a crawlers that digs down through  
this site and extracts botanical info and images...

I will keep trying but it *does* seem Rev has some different  
behaviors here..

Sivakatirswami


On May 09, 2006, at 12:23 PM, Dave Cragg wrote:

>
> On 9 May 2006, at 21:20, Sivakatirswami wrote:
>
>> mmm...  don't know what is going on
>>
>
> Another thought. Are your proxy settings correct? Are you using the  
> same proxy as Firefox is set to use, if it is using one?

Well it has not been an issue before.

I saved as a legacy stack (cool new feature!) and tried it in 2.6

Still get:

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<HTML><HEAD>
<TITLE>400 Bad Request</TITLE>
</HEAD><BODY>
<H1>Bad Request</H1>
Your browser sent a request that this server could not understand.<P>
The request line contained invalid characters following the protocol  
string.<P>
<P>
<HR>
<ADDRESS>Apache/1.3.26 Server at www.msts-my.org Port 80</ADDRESS>
</BODY></HTML>

>
> Cheers
> Dave
> _______________________________________________
> use-revolution mailing list
> use-revolution at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your  
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-revolution




More information about the Use-livecode mailing list