Can't pass array function result as parameter

James Spencer jspencer78 at mac.com
Fri Mar 31 18:59:40 EST 2006


On Mar 30, 2006, at 10:44 PM, J. Landman Gay wrote:

> James Spencer wrote:
>
>> My problem is that while the debugger shows tArray in my mouseUp   
>> handler to be valid and shows it to have been correctly modified,   
>> when I step into the library code for LibUseDifferentArray, it  
>> shows  pArray as empty and the processing fails.  In order to get  
>> it to work  I have had to copy tArray to a new array, element by  
>> element:
>
> Here's an old discussion that may help:
>
> <http://lists.runrev.com/pipermail/metacard/2003-June/005126.html>
>
> Basically, sometimes you can pass an array and sometimes you can't.

Thanks Jacque.  This helped and I believe it has to be describing the  
source of my problem although I haven't completely worked out the  
semantics for my particular case.  Bottom line, it is not a bug per  
se but an artifact of how variables work.  (What I will be playing  
with this weekend is why the "sometimes you can pass an array"  
doesn't seem to include

put functionThatReturnsAnArray(tNonArrayParameter) into tArray
put tArray into tAnotherArray
handlerThatExpectsAnArray tAnotherArray

although in all fairness, this may just be me being sloppy in how I  
tried variations on a theme.

Spence

James P. Spencer
Rochester, MN

jspencer78 at mac.com

"Badges??  We don't need no stinkin badges!"




More information about the Use-livecode mailing list