Copy Image to Clipboard broke in 2.7?

Chipp Walters chipp at chipp.com
Thu Mar 23 16:36:47 EST 2006


I just finished created a charting program, which uses the great new 
anti-aliasing in Rev 2.7.

But, now it turns out copying an image to the clipboard is broke as far 
as I can tell.

Anyone have success doing it on a PC? I've tried on various PC's the 
folowing.

copy image "fred"

doesn't work. Try copying and image and then pasting it into MSPaint or 
anywhere else other than Rev.

Then there's:

set the clipboardData["image"] to image "fred"

Still no go.

and the good old standby, which has worked since the Rev 1.0:

on copyToClip pImage
   set the paintCompression to "png"
   lock messages
   lock screen
   choose select tool
   drag from topleft of image pImage to botright of image pImage
   copy
   unlock messages
   unlock screen
   choose browse tool
end copyToClip

(btw, I've tried setting the paintCompression to all other values).

doesn't work either. I have to say, I really like the new features, but 
I'm routing for an update soon!

best,

Chipp


-- 
--------------
Chipp Walters
www.altuit.com




More information about the Use-livecode mailing list