Weirdness Passing Messages

David Burgun dburgun at dsl.pipex.com
Thu Mar 23 08:03:42 EST 2006


Hi Mark,

I was hoping that you were going to say Version 2.6.6 (which I am  
using), I was going to try it in version 2.7 and was hoping to would  
be fixed! I'm using MacOS 10.4.5 too.

Can anyone check if this works on a different platform? I only have a  
Mac.

Is this a Bug? If so it a *REALLY* fundamental one! The only way I  
can thing to get around this problem 100% is to add a function:

function PutDataIntoMe theLongName,theData
   do "put theData into " & theLongName
end PutDataIntoMe

and use this anytime I want to put data into "me". However, will I  
need a getter too? Also what about this:

enable me
disable me

or

set the visible of me to true

Will these work? Or do I need similar functions to do all this??? The  
reason I mention it is that I just tried:

set the text me of to "ObjectY"

And it doesn't work either???

This has causing me to reevaluate if RunRev is the correct tool to  
use. If something as Fundamental as this doesn't work, what else  
doesn't work?

All the Best
Dave

On 23 Mar 2006, at 12:51, Mark Smith wrote:

> Mac OS 10.4.5, Rev 2.7
>
> I'm also a little concerned about the reliable use of 'me'. I think  
> this hasn't been an issue for me before, because I very rarely have  
> more than 1 card in a stack, but it's good to have discovered this.
> I also would have thought that 'put x into me' would work anytime  
> 'me' is a correct reference, but clearly not...
>
> Best,
> Mark




More information about the Use-livecode mailing list