FTP and cross platform issues...

Mark Schonewille europe at ehug.info
Wed Mar 22 19:56:10 EST 2006


Hi John,

Make sure that both the server and the client (Rev) are set to 
use either passive or active FTP. If you enable passive FTP, you 
have to set Rev's ftp mode to passive as well:

libURLSetFTPMode "passive"

You may have to set the socketTimeoutInterval to a really big 
number.

If you'd like to do a test, I'm working on an FTP client. 
Contact me off-list if you would like to give it a try.

Best,

Mark



John Patten wrote:
> Hello All...
> 
> I searched the archives and could not come up with a solution to an FTP problem I'm having.
> 
> I have an OSX Tiger Server configured for FTP. Everything works like it supposed to with both Fetch (Mac side) and FTP Commander on the WinXP side. No problem.
> 
> However, I've been trying to get the WindowsXP box and Rev to upload a simple text file to the server. No success. I have tried Andre FTP utility, a couple others from the member area, my own hacks using the examples in the rev docs, and finally Chip's FTPer utility. None of them would work. The best I could see was that I was getting a time out error.
> 
> Then I fired up an OSX Tiger Powerbook. I tried Chip's FTPer utility again, same info as on the WindowsXP machine, and it worked without any problem.
> 
> Anybody have an idea why it would work on a MAc and not work on the WindowsXP box?
> 
> Thanks in advance!!
> 
> John Patten
> SUSD

-- 

Consultant and Software Engineer
mailto:m.schonewille at economy-x-talk.com
http://www.economy-x-talk.com

eHUG coordinator
mailto:europe at ehug.info
http://www.ehug.info

Advertise with us and reach 1000 truely interested internet 
users every month. See http://economy-x-talk.com/advertise.html 
for more information.




More information about the Use-livecode mailing list