revolution engine for 2.7 and cgi deployment.

Mark Waddingham 36degrees at runrev.com
Mon Mar 6 05:58:12 EST 2006


Hi Andre,

> Since I moved on to Rev 2.7, I decided to move my cgi stack to the  
> new stack format of 2.7. Before doing that, I tried to install the  
> engine on my Apache installation on my MacOS X 10.4. The engine is  
> playing dead!!!! A simple console hello world works in 2.6.1 and  
> fails on 2.7, it's not like an error is triggered, the engine  
> simply exits without any output or caring for the stack. I even  
> tried a simple script that would wait for a key press to finish and  
> the 2.7 engine simply exits!!!!!
>
> Is this the license issue explained in whats_new.txt? How am I  
> supposed to deploy CGIs using 2.7? I need a license.rev there, if  
> so, how, its a faceless server!! Can someone shed a clue?

In theory you should now be using the Standalone engine for this as  
the IDE engine isn't equipped to be used in this way. However, theory  
never being quite inline with reality, something seems to be up here  
as I couldn't get it to work...

Thus a bug (3367) has been filed and added to my list.

Warmest Regards,

Mark.

------------------------------------------------------------------
  Mark Waddingham ~ 36degrees at runrev.com ~ http://www.runrev.com
        Runtime Revolution ~ User-Centric Development Tools





More information about the Use-livecode mailing list