Postgres problem

Thomas Gutzmann thomas.gutzmann at
Mon Jan 31 01:28:42 EST 2005

Hi Hershel,

on my mac it works with:

pg_ctl start -D /usr/local/pgsql/data -l /usr/local/pgsql/logfile -o -i 

local   all         all                                             
host    all         all   
host    all         all   
host    all         all         ::1               
ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff        trust is the address of my workstation in the LAN.

So this is that what you've done, and it should work. BUT: don't forget 
to open you firewall for 5432:

- open system preferences -> sharing -> firewall
- click on "New"
- add "other" with port number 5432 and give it a nice name
- enable this port

As Len Morgan wrote in his response, test the connection with psql 
before working with Rev. If you don't have Postgres on the remote node, 
you can try "telnet 5432" to see if there is a 
connection at all (end it with QUIT).


Thomas G.

Am 31.01.2005 um 05:28 schrieb Hershel Fisch:

> Hi all, I'm trying to get my postgres to work on a network, I tried to 
> mess
> around with the "pba_config" file
>  host all all trust
>  started with "/usr/local/bin/postmaster -D /usr/local/pgsql/data -i" 
> as I
> use it locally with RR and was not able to get it work on a network.
>  I then tried to change the postgresql.config file and removed the "# 
> " and
> changed tcp/ip to true , didn't do it . Then I changed it back to the 
> way it
> was and … then if I started it without the -Iflag it starts but 
> wouldn’t
> accept any tcp/ip connections even locally so I started it with the –I 
> flag
> ,but wouldn’t start "FATAL: postgresql.conf:1: syntax error, 
> token="#"" .
> Now I can't start postgres with an -i flag at all.
>  and how do I get the network working ? Mac 10.3.
>  I really would appreciate the help.
>  THANKS , A MILL. Hershel

More information about the Use-livecode mailing list