Table field bug/typo in revWriteCellValue

Jerry Balzano gjbalzano at
Mon Jan 17 18:47:38 EST 2005

(this is a resend of a message after several days; please excuse if the  
original manages to get through also)

I was having trouble figuring out how to read and write the contents of  
table fields, so I checked the archive and found a post by Jan Schenkel  
from last September  
044383.html) where he describes how to use the revReadCellValue and  
revWriteCellValue handlers.  I tried these -- actually, the one I tried  
was revWriteCellValue -- without success.  In fact the result of  
calling this handler was the creation of a field on the current card.   
What was going on here? I then took a look at the script of the  
"revTable" button in revLibrary, and I found the following disturbing  
line in the handler (the fifth line in the following):

-- you guessed it, dirty trick upcoming
   lock screen
   lock messages
   create field
   put it inot tFieldRef

I assumed this last line was supposed to be "put it INTO tFieldRef, and  
I even worked up the courage to change it to that (on my laptop copy of  
Revolution) ... but it still didn't work!

I am not terribly conversant with the niceties of "frontScripts" and so  
forth, so this is more of a plea for assistance than anything else.  I  
would really like to be able to read and write cell entries in a table  
field, and I can't seem to do it even though I am using the proper  
handlers and, as far as I can tell, calling them in the proper way  
(actually just following the clear and simple directions Jan provided  
in the 9-30-04 posting).  So, ????

Jerry Balzano


Dr. Gerald J. Balzano
Teacher Education Program
Dept of Music
Laboratory for Comparative Human Cognition
Program in Cognitive Science
UC San Diego
La Jolla, CA 92093
(858) 822-0092


More information about the Use-livecode mailing list