testing on case

Dar Scott dsc at swcp.com
Wed Dec 8 16:55:01 EST 2004


On Dec 8, 2004, at 2:46 PM, Dar Scott wrote:

> If you must avoid a function (sniff, I like functions), then consider 
> this:
>
> if matchText( param(x), "^[A-Z]") then put xxx else put x

or this (if useUnicode is not true and you know it starts with a letter)

if charToNum( param(x) ) < 97 then put xxx else put x

To me a function is more readable.  Are you concerned about speed?

Dar

****************************************
     Dar Scott Consulting
     http://www.swcp.com/dsc/
     Programming Services
****************************************



More information about the use-livecode mailing list