Problems reading from files in the Classic environment

Terry Judd tsj at unimelb.edu.au
Thu Oct 23 21:58:29 EDT 2003


>  > The app works fine when running under OS X and OS 9 but fails when
>>  running in the Classic environment. When I say fails, it starts up  OK,
>>  it's just that it doesn't actually read any data from the
>>  requested files. Thinking that it was a path issue, I queried the
>>  existence of the files at the requested paths (if there is a file
>>  <filePath>), presuming that the problem was path related. The answer
>>  was true but the data was none! Same response even if I resorted to
>>  using the answer file dialog.
>>
>>  Am I missing something basic here or is this a real problem?
>
>I think this is an actual problem.  I was looking at a project today that
>exhibited the same problem.  Works fine in OS X.2.8 and fine in OS 9 but
>in Classic it fails to read the file.  This was using the get url method
>rather than open file.
>

Same here, both get url and open/read methods fail (my app actually 
uses the former, I only really tried the open/read method in an 
attempt to isolate the problem).

-- 
___________________________________________________________________________
Dr Terry Judd

Lecturer in Educational Technology (Design)
Biomedical Multimedia Unit
Faculty of Medicine, Dentistry & Health Sciences
The University of Melbourne
___________________________________________________________________________


More information about the Use-livecode mailing list