CGI again

Jim Lambert jiml at
Wed Mar 12 17:51:03 EST 2003

Now, don't laugh.

I'm trying to use Apple's Personal Web Sharing(PWS) under OS 9.2 to do CGI
with Rev and having little luck. Yes, I know that it's possible to build a
complete server in rev bypassing PWS entirely. But I thought I'd try the
antique, torturous, head-splitting way first!

Tried to set up Actions to launch Revolution first at suffix .cgi then .rev
Neither seemed to work.

I use plain text files ending in .cgi or .rev containing rev startup
Put an alias to Revolution in the same folder as the cgi script and Allow
aliases to open items of outside the Web folder.

Since there's no default cgi-bin folder in PWS how does one handle a CGI
script's engine invocation:

Is that line even necessary with the Actions monkeybusiness?

Regardless of suffix, Rev doesn't launch. Thinking that Applescript may be
involved I made sure Applescript was enabled along with Standard Scripting
Additions. So I tried pre-launching it. Nada.
Just 'A CGI or internal server component could not complete the requested

I checked the list's archives, Rev Web ring sites, and found lots of great
information on doing this under Unix, Linux and Jaguar, but not much for
classic mac. Your advice is much appreciated.

Jim Lambert

More information about the use-livecode mailing list