Standalones from Old HyperCard Stack

Chipp Walters chipp at
Fri Jul 5 03:14:01 EDT 2002

Hey Dan,

Cut my teeth on a bunch of your books, nice to see you're trying out RunRev
/ MC. I spent a few years with SC but left it all behind when I switched to
PC's. Jerry Daniels turned me onto RR 7 or 8 months ago -- and it all came
back. RR/MC is so much better than SC/HC with many more features, compiled
executables and much, much more.

Regarding your second question about the cards... RR executables can't write
to themselves - I believe because Windows and Linux don't allow for
executables to do this sort of thing, so none of the RR/MC versions allow
for this. No problem though, just write to a different stack which is not in
an executable. It would be a separate file. could have your
executable as a startup screen which called the main app - your old HC stack
and things should work fine. Also, you can edit your stack at anytime. You
can also easily update it by storing your stack (this example is test02.rev)
on a website and calling:

open URL ""

from your executable. All very cool. You can check out my RunRev site for
some tips and downloads.

-Chipp Walters

> -----Original Message-----
> From: use-revolution-admin at
> [mailto:use-revolution-admin at]On Behalf Of Dan Shafer
> Sent: Friday, July 05, 2002 2:48 AM
> To: use-revolution at
> Subject: Standalones from Old HyperCard Stack
> I have a simple HyperCard stack I wrote about 300 years ago. My
> wife wants
> to set up her new boss to use it but she's on Windows, so I break out
> Revolution.
> The initial conversion *appeared* to go extremely well. But I've
> encountered some issues and the docs on distribution building that I can
> locate are pretty sparse and not very informative.
> Two problems I've encountered so far.
> There are several navigation buttons on the background. When I run the
> stack in Rev after importing it, these buttons appear and work as
> expected.
> But when I create a distribution, the buttons are not visible. Clicking
> where they are *supposed* to be executes their scripts so I
> figure either I
> have a resource issue or a layering problem.
> I go back to Revolution and I move all of these buttons to the
> front. After
> each such move, i get the following execution error in Revolution:
> * There was an Execution Error at 12:21:07 AM
> Error description: repeat: error in statement
> Revolution User Interface Error: Object: button id 1140 of group
> id 1136 of
> card id 1002 of stack "/Diskourse/Applications/Revolution 1.1 OS
> X/components/tools/revmenubar.rev"
> --------------------
> switch pWhich
> --------------------
> Value: top
> The move seems to have worked, however, because when I build a new
> distribution, I can see the buttons (which are all icons) and
> they seem to
> function.
> So that *seems* to be a cosmetic or bogus bug but someone should
> look into it.
> The real problem I'm dealing with now is that when I add cards to
> the stack
> in the standalone, the changes don't stick. The new cards appear
> fine until
> I exit the app. On restart, only the original cards are still there. if I
> suspend the Rev UI in developer mode and run the stack, I can add
> cards and
> they stick. They even appear in the standalone executable. But
> any cards I
> add don't work.
> Where can I look for help on this issue? Cany anyone shed light here?
> This is tantalizingly close to enabling me to do a bunch of
> fairly powerful
> stuff I've built in the halcyon days of HyperCard and perhaps make it
> successful at last. But I'm clearly missing something!
> Dan Shafer, Chief Scribe and Tablet Keeper
> PythonCard Open Source Project
> _______________________________________________
> use-revolution mailing list
> use-revolution at

More information about the Use-livecode mailing list