Weirdo problem grabbing Gif87a from web sites

bryan mccormick brymac at
Tue Aug 20 23:00:01 EDT 2002

Noticed this only with MC 2.4.3. I have a script that grabs images at an 
interval from a website that creates images on the fly in gif87a format. 
In the past this stack worked beautifully and I had not used it in some 

Dusting it off today I noticed that it worked perfectly except for 
displaying the picture. It appeared totally corrupted. This happened 
whether I was importing the image or using the URL as a file path for 
the image in question.

I manually downloaded the image to see what might be wrong. Other than 
it being Gif87a I could not find anything amiss when I opened it in 
other packages. So I manually converted it to png. Bing, it shows up 
fine in the stack. Going back to the original image I save (gif) and 
setting the file path to the local gif file also showed it as corrupted. 
And to make doubly sure I just switched to the mac and  did the same 
routine. Same issue there.

Anyone have any idea why this is happening?

More information about the Use-livecode mailing list