Android Signing

Ralph DiMola rdimola at
Wed Jun 21 09:44:04 EDT 2023


Now this is starting to be familiar. As I remember it I got an error with
the tool. After many searches I found out there was some problem with the
most recent version of the PEPK tool. I had to download an older version. It
then worked as expected.

Ralph DiMola
IT Director
Evergreen Information Services
rdimola at

-----Original Message-----
From: use-livecode [mailto:use-livecode-bounces at] On Behalf
Of Dan Friedman via use-livecode
Sent: Wednesday, June 21, 2023 1:24 AM
To: How to use LiveCode
Cc: Dan Friedman
Subject: Re: Android Signing


Thank you for the reply.  That is EXACLY what I am doing.  I downloaded the
public key and the PEPK tool.  Pointed the command to the existing keystore
file and got this error: "Cannot find any provider supporting
RSA/NONE/OAEPWithSHA1AndMGF1Padding..."  It looks like there is an error in
the PEPK tool.  "/NONE/" is not a supported encryption!   I would think it
would be "/AES/".


From: use-livecode <use-livecode-bounces at> on behalf of J.
Landman Gay via use-livecode <use-livecode at>
Date: Tuesday, June 20, 2023 at 12:42 PM
To: How to use LiveCode <use-livecode at>
Cc: J. Landman Gay <jacque at>
Subject: Re: Android Signing
On 6/19/23 5:29 PM, Dan Friedman via use-livecode wrote:
> I am trying to update an Android app that was previously release on the
Google Play Store.   When I went to upload the Bundle, I got this message:
> "To upload an Android App Bundle you must be enrolled in Play App
> With a little research, I found the App Signing area under "App
Integrity".   I tried to follow the directions, but I just get errors.
Anyone done this?  If so, do you have any guidance on this?

I had to do this last week with an update to an existing published app on
Google Play. Do you have your original signing key for the app? You'll need
that first. Sign your app as usual with the original key.

Then look at this:

I can't review the necessary Terminal command because I already went through
the process and it isn't available to me now. But originally it gave the
command to generate the Play Store signing key. I already had a pepk.jar
file from before and I used that. I put it into the same directory with Java
because I didn't know how else to do it.

The Terminal command Google provided starts like this:
java -jar pepk.jar --keystore=<yourKeystore.jks> --alias=<your keystore
alias> --output=<create a file name> --encryptionkey=<huge long hex number>

At what point are you getting the errors? My main issue was in getting
Terminal to find Java, it took me a couple of hours and some research to get
the path to Java to work. I know almost nothing about Terminal.

Let us know where you get stuck, though I can't promise I can help. I
congratulate Google on making Android submissions nearly as difficult as
iOS. We need an LC lesson this this.

Jacqueline Landman Gay         |     jacque at
HyperActive Software           |

use-livecode mailing list
use-livecode at
Please visit this url to subscribe, unsubscribe and manage your subscription
use-livecode mailing list
use-livecode at
Please visit this url to subscribe, unsubscribe and manage your subscription

More information about the use-livecode mailing list