OT - Mac Notarization Problem - Desperation setting in

Timothy Bleiler bleiler at buffalo.edu
Fri Aug 25 16:34:24 EDT 2023

I think I’ve solved it.  I’m very grateful to Matthias both for his code signing tool and his personal help with this problem.

In the end it looks like the trouble was caused by a combination of my limited experience with the process and a lack of helpful feedback from Apple’s online tools at critical points.

Here’s what happened.
- I have 2 user accounts on my Mac that use different Apple IDs.

- Somehow the one I use for the Apple developer account had made my Mac NOT a trusted device for the Apple ID I use for development. I have no idea how this happened.
You can verify that your device is trusted at appleid.apple.com<http://appleid.apple.com/> for your account under “Devices”.

- Despite the device not being trusted for the account, the website let me think I’d created an app-specific password. I hadn’t succeed, but my lack of experience prevented me from realizing that the second step of the process is getting the actual password back from Apple and copying it down.  I didn’t get anything, no error message, so in my ignorance I thought the seed string I’d typed in WAS the password. So, I did NOT have an actual app-specific password to use in the NotaryTool commands. This caused all commands dependent on an app-specific password to fail.

What solved it for me was to go to System Settings, sign out of the Apple account on the mac and sign back in again.
Then sign back in to appleid.apple.com<http://appleid.apple.com/>, verify that my Mac was a trusted device on my developer account and then create a NEW app-specific password.
This time I saw the second part when they send the actual password. I think you need to copy this down because I don’t see any way to recover it again later.

Once I had the new app-specific password and my Mac was a trusted device in my developer account, the notaryTool commands worked without errors.

It all makes me long for the days when we could easily pass around Hypercard stacks for the fun of it!!

On Aug 25, 2023, at 2:38 PM, scott--- via use-livecode <use-livecode at lists.runrev.com> wrote:

I use Matthias' brilliant “mrSignNotarizeHelperV4.livecode” project regularly and when I’ve had a problem in the past, ticking the “Debug mode” checkbox (which places each step of the terminal commands in the message box when you click the “Start” button) and then manually entering each of these steps as a command line in Terminal.app, has been helpful in figuring out exactly what step was failing. And sometimes, why.

Scott Morrow

Elementary Software
(Now with 20% less chalk dust!)
web       https://nam12.safelinks.protection.outlook.com/?url=https%3A%2F%2Felementarysoftware.com%2F&data=05%7C01%7Cbleiler%40buffalo.edu%7Ccc7afb2eab1b4bcb60b608dba59aa569%7C96464a8af8ed40b199e25f6b50a20250%7C0%7C0%7C638285855863548154%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000%7C%7C%7C&sdata=%2Fk0TjFvUmYt2BZ9CqydNyA9ZZx34rwuZC3FiprBPQ4s%3D&reserved=0
email     scott at elementarysoftware.com
booth    1-360-734-4701

On Aug 25, 2023, at 8:24 AM, Mark Smith via use-livecode <use-livecode at lists.runrev.com> wrote:

Hi Tim,

Codesigning is (as you probably know) one of the tricker bits of building an app for distribution (and I’ve certainly had my share of failures and frustrations along the way). I am following this thread closely so if you don’t mind sharing, I’d be interested in hearing what the solution is, once you’ve found it.

Cheers and best of luck,

On 25 Aug 2023, at 3:37 pm, Timothy Bleiler via use-livecode <use-livecode at lists.runrev.com> wrote:

Thank you Heather,

I’ll take a look.  Matthias Rebbe is also trying to help me find the problem.

Tim Bleiler

On Aug 25, 2023, at 4:13 AM, Heather Laine via use-livecode <use-livecode at lists.runrev.com <mailto:use-livecode at lists.runrev.com>> wrote:

Tim - codesigning is not my expertise but failed password credentials I deal with frequently :). A possible gotcha is that your password is saved to your keychain, and then, if you change it, the changed password is overwritten by the saved password, invisibly since the password is hidden when entered. I would recommend deleting all saved passwords from your keychain for your certificates etc, and re-entering them to eliminate this possibility.

Probably not the issue but you never know...

Best Regards,


Heather Laine
Customer Services Manager
LiveCode Ltd
https://nam12.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.livecode.com%2F&data=05%7C01%7Cbleiler%40buffalo.edu%7Ccc7afb2eab1b4bcb60b608dba59aa569%7C96464a8af8ed40b199e25f6b50a20250%7C0%7C0%7C638285855863548154%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000%7C%7C%7C&sdata=Eaw78gb3oD9j4XuzyHu%2FdyRRerM%2FT0GunR2oGocDSzM%3D&reserved=0 <https://nam12.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.livecode.com%2F&data=05%7C01%7Cbleiler%40buffalo.edu%7Ccc7afb2eab1b4bcb60b608dba59aa569%7C96464a8af8ed40b199e25f6b50a20250%7C0%7C0%7C638285855863548154%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000%7C%7C%7C&sdata=Eaw78gb3oD9j4XuzyHu%2FdyRRerM%2FT0GunR2oGocDSzM%3D&reserved=0>

On 24 Aug 2023, at 18:02, Timothy Bleiler via use-livecode <use-livecode at lists.runrev.com> wrote:

Hi all,

I believe the problem I’m having is either on Apple’s end or something with my local configuration but Apple has not been very helpful and I’m running out of ideas, so I’m turning to the wealth of experience on this list in desperation.

I’ve been using the lessons from  Matthias Rebbe and V4 of his handy mrSignNotarizeHelper stack.
Code signing seems to work fine but when I get to the Notarization step I always get an
"Error: HTTP status code: 401. Invalid credentials. Username or password is incorrect.

I’m on an M1 Mac with OS 13.4.1, Xcode 14.3.1 is installed, Livecode 9.6.9.

So far, this is what I’ve tried with the same result

1) Verified developer account in good status with Apple
2) Multiple checks of my credentials (Apple ID, team ID, app-specific password) on Apple's developer and ID sites,
3) Multiple checks of my credentials in the parameters I’m using
4) Setting up a new app specific password on my account
5) Trying with a different Livecode application
6 Trying everything manually in Terminal. (What is apparent is any subcommands of NotaryTool (e.g. submit, store-credentials) using my credentials fail with the same error.

7) Repeat everything on a brand new user account on my Mac
8) Sought help through devprograms at apple.com<mailto:devprograms at apple.com>

I’ve done codesigning and notarization many times before with the same developer account with no issues.
What’s new here for me is using NotaryTool and the app-specific password.

I realize this is a long shot but I’m stuck, so it would be great if anyone has any suggestions for solving this problem (even some detail I may have missed in the steps I’ve already taken)


Tim Bleiler, Ph.D.
Instructional Designer, HSIT
University at Buffalo

use-livecode mailing list
use-livecode at lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:

More information about the use-livecode mailing list