OT - Mac Notarization Problem - Desperation setting in

Timothy Bleiler bleiler at buffalo.edu
Thu Aug 24 13:02:32 EDT 2023

Hi all,

I believe the problem I’m having is either on Apple’s end or something with my local configuration but Apple has not been very helpful and I’m running out of ideas, so I’m turning to the wealth of experience on this list in desperation.

I’ve been using the lessons from  Matthias Rebbe and V4 of his handy mrSignNotarizeHelper stack.
Code signing seems to work fine but when I get to the Notarization step I always get an
"Error: HTTP status code: 401. Invalid credentials. Username or password is incorrect.

I’m on an M1 Mac with OS 13.4.1, Xcode 14.3.1 is installed, Livecode 9.6.9.

So far, this is what I’ve tried with the same result

1) Verified developer account in good status with Apple
2) Multiple checks of my credentials (Apple ID, team ID, app-specific password) on Apple's developer and ID sites,
3) Multiple checks of my credentials in the parameters I’m using
4) Setting up a new app specific password on my account
5) Trying with a different Livecode application
6 Trying everything manually in Terminal. (What is apparent is any subcommands of NotaryTool (e.g. submit, store-credentials) using my credentials fail with the same error.

7) Repeat everything on a brand new user account on my Mac
8) Sought help through devprograms at apple.com<mailto:devprograms at apple.com>

I’ve done codesigning and notarization many times before with the same developer account with no issues.
What’s new here for me is using NotaryTool and the app-specific password.

I realize this is a long shot but I’m stuck, so it would be great if anyone has any suggestions for solving this problem (even some detail I may have missed in the steps I’ve already taken)


Tim Bleiler, Ph.D.
Instructional Designer, HSIT
University at Buffalo

More information about the use-livecode mailing list