Ask Password Cursor Oddity

Ralph DiMola rdimola at
Thu Nov 10 13:05:02 EST 2022

Riddle me this..
I was building an Android Production app using 9.6.9 rc2 on Win 10. I kept getting errors that the keystore passwords not correct. I tried it 10 times until I noticed that when typing in the keystore and the private passwords when you type the first character the cursor is before not after the first "*". So if you type "test123" the data is entered as "est123T".
I tried this in the message box (ask password clear "Please provide the keystore password") the form used the in IDE.
Same error. But if you click into the answer's entry field before typing it works as expected. 
It works correctly in 9.6.7. The "clear" option seems to allow typing without having to click into the field.

Can anyone verify if they see the same thing? I also see it on Mac Big Sur. If so I will enter a QCC regression report.


Ralph DiMola
IT Director
Evergreen Information Services
rdimola at

More information about the use-livecode mailing list