iOS 15 and Xcode Cant Install app

Ralph DiMola rdimola at
Thu Sep 30 20:36:15 EDT 2021

I built an ad-hoc iOS app using Catalina 10.15.7 Xcode 12.4 and LC 9.6.3. A tester tried to install and got ("App name" Needs to be updated. The developer of this app need to update it to work with this version of iOS)
I know this was brought up on the list but was there a resolution?
>From the Apple developer site: “Starting April 2022, all iOS and iPadOS apps submitted to the App Store must be built with Xcode 13 and the iOS 15 SDK”
Xcode 12.4 has the iOS 14.4 SDK so I should be OK until 4/2022. The tester had a pre installed version the app that used the iOS 13 SDK built last year that ran OK until they tried to install the new app. Could this be an LC issue (plist?) or did Apple change the rules? It seems that the older SDKs will run but just can't be installed. Is this an ad-hoc app only problem??
I've seen conflicting info while doing some searches.
Does anyone know?
Thanks in advance

Ralph DiMola
IT Director
Evergreen Information Services
rdimola at

More information about the use-livecode mailing list