Android SDK

J. Landman Gay jacque at
Wed Dec 8 16:06:22 EST 2021

Now I'm confused. LC Prefs still says the SDK is invalid but I can build okay directly to my 
phone, which also worked yesterday. So I tried again to build an apk and that now works too, 
though the prefs still show red and report the SDK is invalid (LC 9.6.5.)

There is something weird going on though. I can only build directly to my phone if I choose 
Test from the Development menu. If I just click the Test button in the toolbar I get a dialog 
that says "Android <long number>" which is the ID of my phone. Occasionally the menu item does 
the same, but usually it works.

I wish I hadn't deleted my copy of 9.6.5 rc 2 because there was no problem there. Team: could 
you leave the RC versions up for a few weeks so we could backtrack if necessary?

On 12/8/21 2:33 PM, J. Landman Gay via use-livecode wrote:
> I seem to have ruined my Android SDK setup. It all used to work but I haven't built an app 
> since I installed Big Sur.
> I have installed Android 11 Platform 30, Sources for Android 30, Android SDK Build-Tools 30.0.3 
> (28.0.3 is still in there too) and Android SDK Command-line tools 3.0. I also have some older 
> installations still in place.
> In case there was a permissions issue, I gave everyone "read-only" permissions in Finder for 
> the entire SDK folder and all its contents.
> LC 9.6.5 says the SDK folder is invalid. The same folder used to work as far back as 9.6.1 but 
> now all my LC apps say the folder is invalid.
> So now what?

Jacqueline Landman Gay         |     jacque at
HyperActive Software           |

More information about the use-livecode mailing list