Functions running in IDE, but not running in standalone

Bruce Pokras dangmacguy at
Sun Jul 19 14:17:06 EDT 2020

I am having a very frustrating experience. I have an app called Patent Grabber that is for downloading and searching for patents and published patent applications. A user reported that one feature of Patent Grabber was not working. That was the Abstract Report which takes a list of US patent numbers and downloads basic information about each, and combines all of this information into a single HTML file.

When I tried the Abstract Report in the stack from which Patent Grabber was compiled, the Abstract Report ran fine. However, when I saved the stack as a standalone the Abstract Report did not run. The standalone was NOT frozen. I could immediately run other features without problem.

Since the Abstract Report uses several stack-level functions, I tried adding some “answer” alerts to try to find the bottleneck. All of the “answer” alerts came back under the IDE, and the Abstract Report ran as expected. However, in the standalone, the first couple “answer” alerts came back, but then NOTHING. It was the “answer” alert that I added at the start of a function called getBiblio() that did not come back, and the Abstract Report stopped running.

Now the getBiblio() function is fairly complex. So I replaced it with a three-line function whose first line was an “answer” alert to tell me that the function was running. Under the IDE the “answer” alert came back, but in the standalone, nothing! 

Oh, and one more thing. This was all under Livecode 9.0.1 and also 9.6.0. I also tried compiling the standalone under LC 8.1.9 with the same result. However, when I saved the stack in Livecode 7.0 format, and compiled the standalone using Livecode 7.1.4, all of the “answer” alerts came back and the Abstract Report worked fine!

Any thoughts about this would be greatly appreciated!


Bruce Pokras

More information about the use-livecode mailing list