LC Server - HTTP response code 500: permission denied error

Martin Koob mkoob at
Wed Feb 19 10:12:29 EST 2020

I have RevIgniter 1.7.1 running now and I do want to upgrade to 2.x. as well as upgrade livecode server to the most recent version.

However, I am trying to figure out the smoothest upgrade path.

Would the following process work?
- first upgrade to livecode-server 9.5.1 linux 64 bit
- then test my current api with RevIgniter 1.7.1 on that to make sure it works on my new server
- then do the changes needed in my web api to do the upgrade from RevIgniter 1.7.1 to 2.x
- then do the upgrade to RevIgniter to the latest version 2.1.5



> On Feb 19, 2020, at 9:54 AM, Ralf Bitter via use-livecode <use-livecode at> wrote:
> If your server environment is 64bit and you upgrade your
> revIgniter installation to 2.x then from my point of view there
> is no reason not to use the latest stable LC server version.
> In any case the revIgniter version 2.x requires LC server 9.0
> or higher.
> Ralf
>> On 19. Feb 2020, at 15:09, Martin Koob via use-livecode <use-livecode at> wrote:
>> Hi again Ralf
>> Looking online for that message "not a dynamic executable”  most of the comments talk about missing 32 bit Linux libraries and I checked <> and see that LiveCode 6.1.0 is 32 bit.  So I guess my options are get the host to add the 32 bit Linux libraries or replace livecode-server with the 64 bit version.  The linux 64 bit version I see is  7.0.  Since I want to upgrade LiveCode server anyway  I think I will go with the later.  Any suggestions as to what is the best version to be running.  Are there and changes or upgrades  that need to be made to RevIgniter to ensure compatibility?
>> Thanks for your help.
>> Martin
> _______________________________________________
> use-livecode mailing list
> use-livecode at
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:

More information about the use-livecode mailing list