generating a standalone in v9.x

JJS jjs at
Fri Nov 1 14:20:04 EDT 2019

What you need is described in the release notes from 9.x onwards

Removing the command quit is not the solution

use this, it is copied from the release notes:

on closeStack
if the environment is "development" and \
there is a stack "revStandaloneProgress" and \
the mode of stack "revStandaloneProgress" > 0 then
exit closeStack
end if
end closeStack

i use it always and always works ok.

Op 1-11-2019 om 18:44 schreef Douglas Ruisaard via use-livecode:
> Thanks Bob and Heather and also a thanks to Giovanni Cannizzaro.
> Giovanni had the minimal fix to just remove a "quit" from any "shutDownRequest".
> Heather from LC also offered the following code in a related situation to Giovanni's:
> 	on closeStack
> 		if the mode of stack "revStandaloneProgress" > 0 then
> 			exit closeStack
> 		end if
> 	end closeStack
> The simple fix of removing the "quit" actually allowed the standalone to generate a working executable... HOWEVER, now the build stops with a never-ending "Attaching engine" spinner.  I have to completely exit LC to stop the "unfinished" process.
> I have tried inserting BOTH Heather's and Bob's suggestions but they do NOT resolve the "Attaching engine" issue.
> Any suggestions?
> ps... LC business 8.1.10 still generated the standalone PERFECTLY... even with the v9 changes in the script.  Glad I kept it around!!!  NOT lovin' v9x much at all!
> Douglas Ruisaard
> Trilogy Software
> (250) 573-3935
>> Date: Thu, 31 Oct 2019 22:12:17 +0000
>> From: Bob Sneidar <bobsneidar at>
>> To: How to use LiveCode <use-livecode at>
>> Subject: Re: generating a standalone in v9.x
>> Message-ID: <EA740572-5177-4B16-A839-E6218E17F167 at>
>> Content-Type: text/plain; charset="us-ascii"
>> There is a set of commands that in certain scripts like opesStack and closeStack that will check to
>> see if the standalone builder is running, and then you can abort the handler.
>> The reason they do this is because your app could be doing anything at the moment the standalone is
>> being built. The standalone has to walk through every script to check what add-ons or libraries you
>> use so it can include them.
>> Here's what I do. In the stackScript of the mainStack:
>> on savingStandalone
>>     put true into gBuildingStandAlone
>> end savingStandalone
>> on standaloneSaved
>>     put false into gBuildingStandAlone
>> end standaloneSaved
>> Then in any openStack handler, either in the stack or card, I put this:
>>     put the environment is "development" and \
>>           there is a stack "revStandaloneProgress" and \
>>           the mode of stack "revStandaloneProgress" > 0 into skipLogin
>>     if not skipLogin then
>>     --- code that borks your standalone building. For me it was calling a login dialog as modal.
>>     end if
>> Bob S
>>> On Oct 31, 2019, at 14:50 , Douglas Ruisaard via use-livecode <use-livecode at> wrote:
>>> I am having an issue with using "any" business version of 9 (9.04, 9.05, 9.5-32bit, 9.5-64bit) to
>> generate a standalone output of my application.  I am using Windows 7 Enterprise SP1 and have tried
>> building the identical script (with the same result) on two different installations of said OS on two
>> different machines.
>>> LC business v 8.1.10 generates the standalone fine.
>>> LC business version 9.0.5 (with IDENTICAL settings in the "Standalone Application Settings" as used
>> in the v8.1.10 build) seems to crash LC  just at the point of "closing open stacks" at which point all
>> things LC disappear from my desktop.  An appropriate "destination" directory for the standalone is
>> created as per the settings but it is completely empty.
>>> The actual application runs fine in all LC business versions... it's just that I can't get the LC
>> v9.x to generated the standalone... and ... I can't find ANY error or log explaining what is wrong!!
>>> Is there such a log or audit which details the steps that LC is taking and possibly what the issue
>> is that it cannot resolve?  I have checked at the Administrators tools event logging provided by
>> Windows 7 ... but there is no corresponding event which is simultaneous with the LC "crash".
>>> I follow this user-group quite closely and seem to recall others having issues with LC v9's
>> standalone processes but I cannot seem to find such references within the very large amount of chat
>> this site contains.  I have NOT checked the LC QC bugs since I really don't know what I'm looking for
>> other than potential issues with the standalone builder.
>>> I'd very much appreciate any tips, pointers, explanations as to how to either resolve this issue or
>> where within my LC environment I can find any logs concerning the standalone processing.
>>> Cheers!
>>> Douglas Ruisaard
>>> Trilogy Software
>>> (250) 573-3935
> _______________________________________________
> use-livecode mailing list
> use-livecode at
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:

More information about the use-livecode mailing list