"copy files", specialfolderpath("resources") and missing files =?utf-8?Q?=3D_?=SHOWSTOPPER

Brian Milby brian at milby7.com
Fri Aug 9 22:43:00 EDT 2019


Some files are moved to a different location based on type.  I can’t recall the details and would need to look at the source.  It is related to binary code though.  Stuff is copied first and then moved on a second pass.  That would explain the presence of the empty folders.

Thanks,
Brian
On Aug 9, 2019, 4:47 PM -0400, Klaus major-k via use-livecode <use-livecode at lists.runrev.com>, wrote:
> Maybe noone got the point of my posting?
>
> The point is, that I add files and folder to the standalone via the "Copy files" tab
> in the "Standalone Application Settings", however some of these files are missing
> in the final runtime. However instead they can be found in -> specialfolderpath("engine")
>
> What is happening here and why does LC not copy everything to the RESOURCES folder?
>
> > Am 09.08.2019 um 15:22 schrieb Klaus major-k via use-livecode <use-livecode at lists.runrev.com>:
> >
> > Hi friends,
> >
> > I am currently making an existing app "64Bit safe" for a customer with LC 9.5
> > on macOS 10.14.6.
> >
> > In this app there are some "compiled shell scripts" (? I guess, have no infor about this)
> > which changes the keyboard layout (chinese and back) to german depending of the target
> > fields in LC.
> >
> > Structure (three files and two folders):
> > ## File
> > extSetInputMethod
> >
> > ## Folders
> > x86-64/extSetInputMethod
> > x86-32/extSetInputMethod
> >
> > I guess the first one checks the current architecture and then calls the correct version for this.
> > Whatever, this works fine in the customers older apps.
> >
> > So I added all this via the "Copy files" tab in the "Standalone Application Settings"
> > However these files were NOT in specialfolderpath("resources") in the runtime?
> >
> > In the runtime I find this:
> > the_actual_app.app
> > -> /Resources
> > -> /Resources/Externals ## empty, no externals used in app
> > -> /Resources/x86-64 ## EMPTY!?
> > -> /Resources/x86-32 ## EMPTY!?
> >
> > File -> extSetInputMethod = missing and the two latter folders are EMPTY!?
> > Where on earth are the contents of the other folders?
> >
> > But I find this in:
> > the_actual_app
> > -> /MacOS
> > -> /MacOS/extInputMethod ## the missing file! see above
> > -> /MacOS/x86-64/extInputMethod ## the missing file
> > -> /MacOS/x86-32/extInputMethod ## the missing file
> > ...
> >
> > So calling the shell apps in -> specialfolderpath("resources") does of course not work!?
> > If I copy them manually to the correct folder in the runtime, they stop working.
> > So all in all this is a real showstopper! :-/
> >
> > Am I overlooking something?
> > Is this correct behaviour of LC?
> > What can I do?
>
> --
> Klaus Major
> https://www.major-k.de
> klaus at major-k.de
>
>
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode



More information about the Use-livecode mailing list