not building standalone due to password protected stack LC950Indy

JJS jjs at krutt.org
Fri Aug 9 12:57:46 EDT 2019


Yep,


that was it.

For this stack i had automatically search inclusions set to true.

So when the stack is encrypted it does not work.

Manually it works ok.

Damn, that i did not check it in the first place. The error was obvious.

So it is a bug, as it should also work.

Will report it.


Thanks,

Sphere


Op 9-8-2019 om 18:47 schreef JJS via use-livecode:
> Hi,
>
>
> this build was for windows 32 and 64 bit, and building on win10-64bits.
>
> i can not recall this issue with a lc950dp or rc version when building 
> an encrypted stack for Android.
>
> Perhaps the difference is that for that i selected inclusions 
> mannually i'm now thinking.
>
> I will check if that is the difference here.
>
>
> Thanks,
>
> Sphere
>
>
> Op 9-8-2019 om 17:29 schreef Pi Digital via use-livecode:
>> Hi
>>
>> I’ve only noticed this when building for HTML5. For everything else 
>> the stacks get directly included and don’t care that they are 
>> password protected. For html they have to get re-coded through 
>> emscripten which is where I believe the issue arises.
>>
>> Which platform/s are you trying to deploy for and what machine type 
>> are you using to build the standalone?
>>
>> Sean Cole
>> Pi
>>
>>> On 9 Aug 2019, at 16:09, JJS via use-livecode 
>>> <use-livecode at lists.runrev.com> wrote:
>>>
>>> Hi,
>>>
>>>
>>> i've not seen this before:
>>>
>>> Could not auto-detect inclusions or security categories because 
>>> stack is password protected
>>>
>>>
>>> It seems like setting the password for stacks in the standalone 
>>> setting is not working. If i set it and save the stack, then open 
>>> the stack in notepad++ i can read all.
>>>
>>> When i use: Set the Password of stack"encryptme" to 
>>> "thisisapassword" and do the same thing in notepad++ it is all 
>>> jibberish as expected.
>>>
>>> But then i load it again in LC950Indy, and i get above mentioned error.
>>>
>>> Same error when i open a script and enter the password, even then 
>>> it's not able to build.
>>>
>>>
>>> In previous LC versions this was working correct.
>>>
>>> Anyone seen this?
>>>
>>> Is there a quick fix?
>>>
>>>
>>> Thanks!
>>>
>>>
>>> Sphere
>>>
>>>
>>>
>>> _______________________________________________
>>> use-livecode mailing list
>>> use-livecode at lists.runrev.com
>>> Please visit this url to subscribe, unsubscribe and manage your 
>>> subscription preferences:
>>> http://lists.runrev.com/mailman/listinfo/use-livecode
>> _______________________________________________
>> use-livecode mailing list
>> use-livecode at lists.runrev.com
>> Please visit this url to subscribe, unsubscribe and manage your 
>> subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
>
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your 
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode




More information about the Use-livecode mailing list