increasing column width of DG keeps running

Tom Glod tom at makeshyft.com
Thu Aug 1 16:31:59 EDT 2019


the runaway number thing was happening to me when changing row height on dg
using the arrow in the property inspector...... but never with column width.

On Thu, Aug 1, 2019 at 3:45 PM JJS via use-livecode <
use-livecode at lists.runrev.com> wrote:

> Yes indeed.
>
> So some 'tiny' things we still have.
>
> Also i had multiple lines of text on one row. I increased the row
> height. looked ok in the IDE but had the issue on mobile. I had to
> remove te DG and template, reopen the stack, and drag a new dg on it.
> After that 2 other DG's on other cards starts complaning they can't find
> their column behavior and opening the LC script of it, revsomething. So
> ultimately i also replaced these DG's(now without replacing the
> template). All works again.
>
> This is kind of doable when the Style is form, but not when it is table.
>
> If i do a dispatch"ResetList" to the group then i see the error again,
> so i commented it out.
>
> So before every major change on a DG it's best to save a copy first.
>
> Maybe i will report a bugreport on the increase issue.
>
> But further i'm happy with the DG's as they have a lot of potential.
>
>
> Op 1-8-2019 om 19:23 schreef Bob Sneidar via use-livecode:
> > That's a long standing issue and I think it has to do with the way the
> TreeView widget is implemented. Correct me if I am wrong. When I create a
> column in the Datagrid, after naming it, I then have to click the column
> AGAIN to get it to refresh. Really frustrating.
> >
> > Bob S
> >
> >
> >> On Aug 1, 2019, at 08:08 , Paul Dupuis via use-livecode <
> use-livecode at lists.runrev.com> wrote:
> >>
> >> I did see a bug when editing column names. Add a column. Type in the
> Column name. The click on the Column label field of the PI and types a
> label. Press tab, get an error "object does not have that property" and the
> Col # name references as the object. I think the closeField handler in the
> PI for the column name is broken.
> >>
> >> I report the bug I found to the Quality Center as
> https://quality.livecode.com/show_bug.cgi?id=22281
> >
> > _______________________________________________
> > use-livecode mailing list
> > use-livecode at lists.runrev.com
> > Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> > http://lists.runrev.com/mailman/listinfo/use-livecode
>
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>



More information about the Use-livecode mailing list