Android Studio how to create AVD?

chipsm at themartinz.com chipsm at themartinz.com
Tue Mar 6 21:43:26 EST 2018


The links that you provided don't seem to work. I get a 404 error

-----Original Message-----
From: use-livecode [mailto:use-livecode-bounces at lists.runrev.com] On Behalf Of panagiotis merakos via use-livecode
Sent: Friday, March 02, 2018 4:03 AM
To: How to use LiveCode <use-livecode at lists.runrev.com>
Cc: panagiotis merakos <merakosp at gmail.com>
Subject: Re: Android Studio how to create AVD?

Hi Bob,

Just a suggestion, I personally find it easier to download an install just the Android SDK Tools, not Android Studio.

The problem is that the newest versions of the Android SDK Tools don't work well with LC, because you can mainly run commands from the command line instead of having a UI for Android AVD Manager and Android SDK Manager etc So you have to download an older version of the Android SDK Tools.

I have installed version 19 and it works like a charm with all LC versions I have tried (from 6.7.11 to 9.0)

The link is a bit difficult to find, it has this format:

http://dl-ssl.google.com/android/repository/tools_r[rev]-windows.zip
http://dl-ssl.google.com/android/repository/tools_r[rev]-linux.zip
http://dl-ssl.google.com/android/repository/tools_r[rev]-macosx.zip

For example http://dl-ssl.google.com/android/repository/tools_r19-macosx.zip
for version 19 on Mac.

On other machines I have installed more recent versions, I *think* 20-23, and they work fine too.

After downloading an older version of the Android Tools, use the instructions in this lesson http://lessons.livecode.com/m/2571/l/27389-how-do-i-become-an-android-developer-on-a-mac

to download the other dependencies (SDK Platform Android 4.0.3 package) using the Android SDK Manager and configure Android AVD Manager.

Hope this helps,
Panos
--


On Fri, Mar 2, 2018 at 11:39 AM, bob--- via use-livecode < use-livecode at lists.runrev.com> wrote:

>
> >
> > Once you've done that you can choose Tools > Android > AVD Manager 
> > and create a device. You'll need to choose something with armeabi
> architecture,
> > not x86, when you create the device. Once it has booted up you 
> > should see it in the target list.
> >
>
> Thanks for the clearing this up Ali. When I go to the Tools menu 
> Android is not listed. BUT, you gave me a hint as to what was up. I 
> did some searches and it turns out that there’s still an issue with 
> the default installation of Android Studio — apparently, in Googles 
> infinite wisdom, the Android menu is not installed with the default 
> configuration (dope slap to Google). You need to select custom install 
> and add the AVD and other options for installation.
>
> I had 2 options to get things working. Completely uninstall Android 
> Studio (not something I wanted to tackle since it’s not just uninstall 
> the app and I use JetBrains for other dev work) or let AStudio fix 
> itself. I choose Option 2.
>
> Option 1 Uninstall: https://stackoverflow.com/ 
> questions/47272832/no-android-option-in-tool-menu-and-no-avd-manager <
> https://stackoverflow.com/questions/47272832/no-android-
> option-in-tool-menu-and-no-avd-manager> <— for windows, mac looks 
> option-in-tool-menu-and-no-avd-manager> similar
> Option 2 Let AStudio fix itself: https://stackoverflow.com/ 
> questions/46948322/how-to-open-avd-manager-in-android-studio-3-0-versi
> on <
> https://stackoverflow.com/questions/46948322/how-to-
> open-avd-manager-in-android-studio-3-0-version>
>
> Not out of the woods yet but I do have the Android menu now (YIPEE!).
>
> I’ve created a AVD (Nexus 5 API 15 IceCreamSandwidch). I had installed 
> this from the configuration menu of AStudio. When I tried to created 
> an AVD I got an error:
> "Emulator: emulator: ERROR: This AVD's configuration is missing a 
> kernel file! Please ensure the file "kernel-qemu" is in the same 
> location as your system image.”
> "Emulator: emulator: ERROR: ANDROID_SDK_ROOT is undefined”
>
> I went back and created a API 17 based AVD. This device is able to 
> boot after I downloaded the image.
>
> Back to LC. Development->Test Target and select the Android emulator. 
> Then
> Development->Test.
>
> LC: “Unable to build app for testing: could not compile Application class”
>
> Troubleshooting continues but thanks for moving me forward.
>
> Bob H.
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your 
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
_______________________________________________
use-livecode mailing list
use-livecode at lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode





More information about the Use-livecode mailing list