Android, acceleratedRendering and visual effect

panagiotis merakos merakosp at gmail.com
Sat Jul 21 22:09:24 CEST 2018


Ok nice, I know what happened. I will post a detailed msg in a while as I
am not in a computer now.

Best,
Panos

On Sat, Jul 21, 2018, 21:05 Dan Friedman <dan at clearvisiontech.com> wrote:

> Odd… I uninstalled the app from the Android phone and re-installed it.
>  Now it installed.   Go figure.
>
> -Dan
>
>
> On 7/21/18, 12:53 PM, "use-livecode on behalf of panagiotis merakos via
> use-livecode" <use-livecode-bounces at lists.runrev.com on behalf of
> use-livecode at lists.runrev.com> wrote:
>
>     Can you try setting the app identifier in the standalone settings to
>     something unique that definitely is not already installed in the
> device? Is
>     it possible that you have installed an app with the same identifier
>     (com.yourcompany.yourapp) in the device, which was built with 9.0.1
> rc1?
>
>     On Sat, Jul 21, 2018, 20:45 panagiotis merakos <merakosp at gmail.com>
> wrote:
>
>     > Hello Dan,
>     >
>     > What is the version of Android the device is running? I am wondering
> if
>     > you get this error because of the value of the targetSdkVersion set
> in the
>     > manifest.
>     >
>     > Best,
>     > Panos
>     >
>     > On Sat, Jul 21, 2018, 20:32 Ray via use-livecode <
>     > use-livecode at lists.runrev.com> wrote:
>     >
>     >> Are you having this problem only on other users' Macs?  If so then
>     >> you've run into the same Apple induced problem I posted about a
> month
>     >> ago.  It only happens when you distribute to others using MacOS
> 10.12 or
>     >> higher.
>     >>
>     >>
>     >> On 7/21/2018 2:29 PM, Dan Friedman via use-livecode wrote:
>     >> > So, I tried to revert back to 9.0.0 because my client is pretty
> pissed
>     >> that we’ve missed our deadline.  Unfortunately, when I save as
> standalone
>     >> in 9.0.0, and try to install it on a device, the device reports
> that “the
>     >> package appears to be corrupt”.  I tried changing the build number
> (as
>     >> Jacque suggested in a related thread (
>     >> https://forums.livecode.com/viewtopic.php?t=29624)), but that did
> not
>     >> solve the problem.   Is there something I need to do to the stack
> to revert
>     >> back to 9.0.0 from 9.0.1?
>     >> >
>     >> > FYI, I did all the obvious things like reset the standalone
> settings,
>     >> uninstall the old app on the phone, etc.
>     >> >
>     >> > At this point, I would be grateful for ANY advice.
>     >> >
>     >> > -Dan
>     >> >
>     >> >
>     >> > On 7/20/18, 6:27 AM, "use-livecode on behalf of Dan Friedman via
>     >> use-livecode" <use-livecode-bounces at lists.runrev.com on behalf of
>     >> use-livecode at lists.runrev.com> wrote:
>     >> >
>     >> >      Monte,
>     >> >
>     >> >      Thanks!   I have a client waiting… should I revert back to
> 9.0.0?
>     >> Or is there a 9.0.1 rc2 coming SOON?
>     >> >
>     >> >      -Dan
>     >> >
>     >> >
>     >> >      On 7/19/18, 5:17 PM, "use-livecode on behalf of Monte
> Goulding via
>     >> use-livecode" <use-livecode-bounces at lists.runrev.com on behalf of
>     >> use-livecode at lists.runrev.com> wrote:
>     >> >
>     >> >          Hi Dan
>     >> >
>     >> >          A little update.
>     >> >
>     >> >          The bug report is here:
>     >> >          https://quality.livecode.com/show_bug.cgi?id=21434 <
>     >> https://quality.livecode.com/show_bug.cgi?id=21434>
>     >> >
>     >> >          The PR for the fix is here:
>     >> >          https://github.com/livecode/livecode/pull/6610 <
>     >> https://github.com/livecode/livecode/pull/6610>
>     >> >
>     >> >          Cheers
>     >> >
>     >> >          Monte
>     >> >
>     >> >          > On 20 Jul 2018, at 9:54 am, Monte Goulding via
> use-livecode <
>     >> use-livecode at lists.runrev.com> wrote:
>     >> >          >
>     >> >          > Hi Dan
>     >> >          >
>     >> >          > This looks like a regression from the large number of
>     >> acceleratedRendering related patches that went into 9.0.1 rc 1. I am
>     >> looking into it as it will be a blocker for 9.0.1-rc-2.
>     >> >          >
>     >> >          > Cheers
>     >> >          >
>     >> >          > Monte
>     >> >          >
>     >> >          >> On 20 Jul 2018, at 4:13 am, Dan Friedman via
> use-livecode <
>     >> use-livecode at lists.runrev.com> wrote:
>     >> >          >>
>     >> >          >> Hello!
>     >> >          >>
>     >> >          >> Using LC 9.0.1 (rc1), on android only, if I have
>     >> acceleratedRendering on, the effect is not applied when doing this:
>     >> >          >>
>     >> >          >> lock screen for visual effect
>     >> >          >> //do something
>     >> >          >> unlock screen with visual effect wipe left //any
> effect
>     >> fails
>     >> >          >>
>     >> >          >> However, if acceleratedRendering is off, the visual
> effect
>     >> is applied.
>     >> >          >>
>     >> >          >> Any thoughts?
>     >> >          >>
>     >> >          >>
>     >> >          >> -Dan
>     >> >          >>
>     >> >          >> _______________________________________________
>     >> >          >> use-livecode mailing list
>     >> >          >> use-livecode at lists.runrev.com
>     >> >          >> Please visit this url to subscribe, unsubscribe and
> manage
>     >> your subscription preferences:
>     >> >          >> http://lists.runrev.com/mailman/listinfo/use-livecode
>     >> >          >
>     >> >          >
>     >> >          > _______________________________________________
>     >> >          > use-livecode mailing list
>     >> >          > use-livecode at lists.runrev.com
>     >> >          > Please visit this url to subscribe, unsubscribe and
> manage
>     >> your subscription preferences:
>     >> >          > http://lists.runrev.com/mailman/listinfo/use-livecode
>     >> >
>     >> >          _______________________________________________
>     >> >          use-livecode mailing list
>     >> >          use-livecode at lists.runrev.com
>     >> >          Please visit this url to subscribe, unsubscribe and
> manage
>     >> your subscription preferences:
>     >> >          http://lists.runrev.com/mailman/listinfo/use-livecode
>     >> >
>     >> >
>     >> >      _______________________________________________
>     >> >      use-livecode mailing list
>     >> >      use-livecode at lists.runrev.com
>     >> >      Please visit this url to subscribe, unsubscribe and manage
> your
>     >> subscription preferences:
>     >> >      http://lists.runrev.com/mailman/listinfo/use-livecode
>     >> >
>     >> > _______________________________________________
>     >> > use-livecode mailing list
>     >> > use-livecode at lists.runrev.com
>     >> > Please visit this url to subscribe, unsubscribe and manage your
>     >> subscription preferences:
>     >> > http://lists.runrev.com/mailman/listinfo/use-livecode
>     >>
>     >>
>     >> _______________________________________________
>     >> use-livecode mailing list
>     >> use-livecode at lists.runrev.com
>     >> Please visit this url to subscribe, unsubscribe and manage your
>     >> subscription preferences:
>     >> http://lists.runrev.com/mailman/listinfo/use-livecode
>     >
>     >
>     _______________________________________________
>     use-livecode mailing list
>     use-livecode at lists.runrev.com
>     Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
>     http://lists.runrev.com/mailman/listinfo/use-livecode
>
>


More information about the use-livecode mailing list