9.0 Crashes Constantluy

William Prothero waprothero at gmail.com
Tue Apr 10 12:29:10 EDT 2018


BR:
I have not tried to build standalones during the last few releases, but with the latest 9.0.0, I am. I notice that when I build my standalone, it loads all of the stacks in the “Stacks” list (in standalone settings. Also, I use a splash stack approach) and leaves them in memory. So, when I want to do a debug after building and trying the standalone, I have all of my stacks loaded and it interferes with my workflow. I’d really like the project to return to the state I started with. It also seems to run scripts in my project which sets various globals. Note: I have implemented Panos’ suggestion to test for the mode of stack “revStandaloneProgress”.  I have a script that returns the project to it’s initial state, but to be safe, I find this behavior forces me to quit livecode and reload it, to make sure my project is returned to its initial state for continued debugging.

This seems like an undesirable behavior. I can live with it, but ….

Best,
Bill

William A. Prothero
http://earthlearningsolutions.org

> On Apr 10, 2018, at 8:47 AM, Sannyasin Brahmanathaswami via use-livecode <use-livecode at lists.runrev.com> wrote:
> 
> 9.0 gm is the most unstable version in a long time
> 
> Constantly crash on exit.
> 
> I set break point, set to debug mode, run script… it does not break that break point… run it again, crash.
> Scripts are setting, applied "green button" close, saved. Re-opened "what happened to my changes?"
> 
> Anyone else having these problem?
> 
> Look like I have to go back to 8.1.9 to get work done.
> 
> BR
> 
> 
> 
> 
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode




More information about the Use-livecode mailing list