Remote debugging - expected behavior

panagiotis merakos merakosp at gmail.com
Thu Sep 28 21:16:17 CEST 2017


Hi Jacque,

This is the expected behaviour. The remote debugger is included in the
standalone when you click on the Test button, even if you don't select it
in the Inclusions (the same applies to Android Internet permission).

See the discussion in this bug report:

http://quality.livecode.com/show_bug.cgi?id=19370

If you think this is not expected behaviour, please file a report for us to
reconsider.

A workaround to prevent the remote debugger from being included in the
standalone is to turn off the wifi in your Android device (or connect to a
different network than the one your machine is connected to). I have not
tested it but I suppose it will work.

Best,
Panos
-- 

On Thu, Sep 28, 2017 at 7:45 PM, J. Landman Gay via use-livecode <
use-livecode at lists.runrev.com> wrote:

> What is the expected behavior of remote debugging? I'm not sure if what I
> see is how it is supposed to work, or a bug.
>
> I have an app that does not have the remote debugger included in the
> Inclusions pane. Looking at the revStandaloneSettings custom properties, it
> is (correctly) not in there either.
>
> Every time I do a test build, LC asks if I want to start a remote
> debugging session. Until I noticed the dialog, I thought the app had hung
> on launch. I have to provide a response on every test build before the app
> will run. Also, even if I just relaunch the app after installation, it asks
> again. Basically I can't run the app without replying to the dialog. Is
> this correct behavior?
>
> Also, as I mentioned before, if I say "yes" to the dialog, and quit the
> app via the Home or App Switcher, there is no message that debugging has
> been discontinued. I am pretty sure that's due to the fact that LC doesn't
> send any messages with those keys. At any rate, when that happens, the
> scripts can't be edited as they are still in a locked state and I can't
> find a way out of that unless I quit and relaunch LC.
>
> What is the expected behavior? There's no toggle to control remote
> debugging.
>
> --
> Jacqueline Landman Gay         |     jacque at hyperactivesw.com
> HyperActive Software           |     http://www.hyperactivesw.com
>
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>


More information about the use-livecode mailing list