OSX module file error when building standalone with LC 8 on mac

Bob Sneidar bobsneidar at iotecdigital.com
Wed Mar 15 10:44:53 EDT 2017

I dunno, but I do notice that when compiling (I call creating a standalone "compiling" because it takes less effort to type) the standalone builder "actually opens" stack files. I know this because I have handlers which, upon opening the mainstack for the first time, opens a substack I use for logging into the database. This stack is opened modally by script. The stack is NOT set to float above everything itself. 

This means that when the standalone builder opens stacks THEY ARE ACTUALLY running the handlers! This did NOT happen with version 8.0.x so far as I can tell. Also try manually setting your inclusions instead of letting the builder automatically figure it out. Thirdly, check your standalone settings and stack files in the mainstack to make sure that the builder did not modify these! If you build for more than one OS at a time, these can get modified to use inclusions IN THE STANDALONE FOLDER of another versions build! 

I know you are saying, "That is crazy mad sh*t! Whe the H**l would they do that????? At least that is what I have been saying. 

Bob S

> On Mar 14, 2017, at 22:48 , James Hale via use-livecode <use-livecode at lists.runrev.com> wrote:
> I just went to recompile a little utility I have and came across this error.
> The stack is simple and just gets the user to select file(s) or a folder or a text list to create folders somewhere else.
> I had compiled a standalone before but now am unable to with LC8.
> It gets all the way to building MacOS components and then...
> "There was an error while saving the
> standalone application
> Build failed for MacOSX x86-32: could not
> open module file"
> I originally was compiling 64 bit, then I tried both, then just 32 bit.
> Same error in each case.
> Has anyone else experienced this?
> Does anyone know what it means?
> Tried with 
> 8.1.3 indy and business
> 8.1.0 Indy
> Then tried with a couple of the 9DPs
> These all worked!
> So it seems to be only with the LC 8s that I have.
> James

More information about the use-livecode mailing list