[ANN] Release 8.1.5 -- tsneterr

Matthias Rebbe matthias_livecode_150811 at m-r-d.de
Tue Jul 11 21:26:12 CEST 2017


Dan,

before creating the standalone you can disable the tsNet external
To unload:

  dispatch "revUnloadLibrary" to stack "tsNetLibUrl"

To load again:
  dispatch "revLoadLibrary" to stack “tsNetLibUrl"

Regards,
Matthias

Matthias Rebbe
+49 5741 310000
‌matthiasrebbe.eu <http://matthiasrebbe.eu/>‌

> Am 11.07.2017 um 19:33 schrieb Dan Friedman via use-livecode <use-livecode at lists.runrev.com <mailto:use-livecode at lists.runrev.com>>:
> 
> I am porting a large project from LC 7 to 8.1.5.  Occasionally, I get this error when accessing the internet:  “tsneterr: Not initialised” (misspelled, by the way).   It works fine for a while, then it just fails.  And, once it fails you have to completely restart.  Sometimes LC even crashes!
> 
> It seems to be happening when one network connection isn’t finished and it tries to start another one.   I did not have this problem in LC 7 using libURL.  So, I’m pretty confident it’s something with tsNet.
> 
> If it’s because tsNet calls are crashing into each other, and If all calls [by default] are blocking, how could one connection be started before the previous one is completed?
> 
> I had this problem with previous versions of 8.1, but I was hoping it would be fixed in 8.1.5.
> 
> Anyone have any insight?   I would very much like to move forward with tsNet, but if this isn’t resolved, I can’t.  Is it possible to continue with 8.1.5, and still use the old libURL?
> 
> 
> -Dan
> 
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com <mailto:use-livecode at lists.runrev.com>
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode



More information about the use-livecode mailing list