dunbarx at aol.com
dunbarx at aol.com
Sun Jun 19 07:32:56 EDT 2016
Whatever we might wish for, "objects" in and of itself does not exist in LC. It is just a mental construct, a remnant of HC days. I think that way, too, but also know that:
You cannot: "answer the number of objects."
though you surely can: "answer the number of controls"
I doubt the team would think this very important.
From: Richmond <richmondmathewson at gmail.com>
To: How to use LiveCode <use-livecode at lists.runrev.com>
Sent: Sun, Jun 19, 2016 6:44 am
Subject: Re: Control? Object?
If 'Object' is a reserved word, then why is the Dictionary "we all know
and love" full of 'objects':
Looking up 'focusedObject' one can read:
"Returns the currently focused control"
So there is no question of 'reserved words'; there is a simple case of a
BAD confusion that needs to be sorted out, 2 words being used for one
thing, or, rather
one set of things:
1. Dump the word 'object' and only use 'control', or
2. Dump the word 'control' and only use 'object'.
Personally I prefer #2.
This is an "issue" [ a.k.a. 'fudge' ] that has been left unfixed for
far, far too long.
Presumably (?) this is something that can be sorted out pretty quickly
On 19.06.2016 11:03, David Bovill wrote:
> I have the same issue :)
> I started a long time ago to name handlers with the concept of "object"
> rather than "control" - it was more intuitive. The word "object" has
> associations for the new user which makes it easier to grasp the related
> concepts of "property" and so forth. Livecode is rooted in the
> object-oriented paradigm of small-talk, and HyperCard - and many of the
> concepts such a "stack", "card" and "field" etc are layered on top of this
> metaphor. The problem is that they are not pure objects in a technical
> sense, and the term is sort of reserved for a possible future expansion of
> the vocabulary. I am not sure if this will ever happen, and in the mean
> time we are left with a clear metaphor, and a confusing reality. I've
> decided to live with it :)
> So when I refer to a "field" in a variable I use "fieldObject" rather than
> "fieldControl", or with a virtual property I use "put the field_Object of
> this card..." rather than "field_Control". This is partly because i don;t
> want to confuse (myself) and other readers with a terminology that sound
> too much like Model View Controller architecture - or the idea that you are
> "doing something" ie "controlling" the concept in question.
> So my answer is that while creating an abstraction in how I code, I name
> things using the best metaphor I can find, so often I will think in terms
> of concrete objects, with properties that may or may not be implemented
> with a "control", a "group", or more recently a "widget". The most abstract
> concept is "object" which can refer to any of those - but I try to avoid it
> where possible and use a more explicit name of the term "view" - so
> "textView" or "the index_View of this card".
> On 19 June 2016 at 08:19, Richmond <richmondmathewson at gmail.com> wrote:
>> I am currently teaching some children Livecode programming and ran into
>> some difficulty
>> on Friday when a child asked me why the menus were full of the word
>> when I had been talking about "Objects".
>> How about changing every use of the word "Control" to "Object"?
>> Enhancement Request 17879
>> use-livecode mailing list
>> use-livecode at lists.runrev.com
>> Please visit this url to subscribe, unsubscribe and manage your
>> subscription preferences:
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
use-livecode mailing list
use-livecode at lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
More information about the Use-livecode