Charset problems with .lc web page

Tim Selander selander at tkf.att.ne.jp
Tue Jan 5 09:14:34 EST 2016


Hi Peter,

Thanks for the tip. However, it didn't seem to do anything for 
me. According to the trick Alex told me about getting the server 
version, the On-rev account I'm using has livecode-server-6.6.2 
installed.

FWIW, Kojima-san's tip worked great; it's in another post in this 
thread.

Appreciate everyone's help with this!

Tim Selander
Tokyo, Japan


On 1/4/16, 20:39, Peter TB Brett wrote:
> On 24/12/2015 07:55, Tim Selander wrote:
> > Dear list,
> >
> > I'm having trouble making a .lc web pages correctly show the 
> charset.
> >
> > I have two test files:
> > http://www.pba.on-rev.com/5_today.lc
> > http://www.pba.on-rev.com/5_today.irev
> >
> > They are identical except for the .lc/.irev file extensions, 
> and also
> > the <?lc ?> and <?rev ?> tags in the html.
> >
> > The .irev file correctly shows Japanese UTF8, the .lc file 
> does not.
> >
> > Anyone else having problems with this? Can .lc files not 
> handle charset
> > correctly?
>
> Hi Tim,
>
> I think that if you put a comment like:
>
>     -- encoding: utf8
>
> in the first line of the .lc file (or the second line if you 
> have a shebang), the server engine will treat the .lc file as 
> UTF-8 text rather than native text.
>
> On the other hand, that solution might not work except in 
> LiveCode 6.7 or later.  I'm not sure!
>
>                                    Peter
>





More information about the Use-livecode mailing list