Cursor changes to a hand in the ide

Jim Byrnes jf_byrnes at comcast.net
Thu Feb 25 23:42:02 CET 2016


On 02/25/2016 03:53 PM, Mark Wieder wrote:
> On 02/25/2016 12:44 PM, Jim Byrnes wrote:
>> On 02/25/2016 11:16 AM, Richard Gaskin wrote:
>>> Jim Byrnes wrote:
>>>  > At the point the problem occurred I hadn't written a line of code.
>>>  > I had dropped a label control on the card and expanded it's size.
>>>  > Then I dropped 2 radio buttons inside the boundaries of the of the
>>>  > label. I was renaming them and changing the label text when the
>>>  > problem occurred.
>
> I also can't replicate your problem, but I'm curious about what you were
> trying to accomplish here... dropping radio buttons "inside the
> boundaries of the label" will place them in front of the label (I'm not
> going to get into the religious war of whether they're "above" or
> "under" the label in the message path), but they're otherwise not
> connected with the label.

When I start to teach myself a new language I usually read the docs, do 
some tutorials and for practice recreate a program I have written in 
other languages. In this case a simple little program to store some info 
in a sqlite db.

The other environments I have used had a control that was essentially a 
box with a border around it. At the left end of the top border you could 
embed a label in the border itself. You could then drop other controls 
inside the box. It just called attention to certain controls.

I didn't see anything like that in Livecode and was experimenting to see 
if I could create the effect.

> I do find it buggy that if I follow your procedure and then click on the
> label text to select the large-border label, I am then unable to select
> the buttons, even though they are in front of the label, without first
> clicking somewhere else to deselect the label field. I'll file a bug on
> that one.
>
> As far as the cursor changing to a hand, it sounds like you've entered
> Browse mode instead of Edit mode. I don't use the tool palette myself,
> but I think there may be a control-key sequence that toggles between the
> modes, and you may have accidentally triggered that. In PowerTools the
> sequence is control-tab, so you might give that a try.
>

Here ctrl-tab toggles the tool palette. I tried a number of modifier 
keys + another key combinations with no effect.  To me it looks like I 
am stuck in run mode.  I can drag a control off of the palette and drop 
it on the stack, but it just disappears.

Regards, Jim





More information about the use-livecode mailing list