[TRYING AGAIN] Secure Sockets Issue

Stephen MacLean smaclean at madmansoft.com
Tue Feb 2 17:40:05 CET 2016


Hi All,

Going to give this another go:

I can not get two LC apps to connect and transmit to each other via secure sockets. They connect fine and transmit fine without trying to secure them.

As far as I can tell, doing this on the server:

 accept secure connections on port 5210 with message  “someoneConnected"

And this on the client:

 open secure socket to (field "host" & ":5210") with message “chatConnected"	

Should create a secure connection between the two apps.

However, doing so, while the client does connect to the server, when the client sends data to the server, the socket just closes. No error is returned. 

By removing the secure keyword form the server script, when the client sends data, the following error is returned:

error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol

The client then closes the socket without firing the “socketClosed” message

—————————

In researching this, I’ve come across the lesson on LiveCode.com <http://livecode.com/>: http://lessons.livecode.com/m/4071/l/12924-how-to-communicate-with-other-applications-using-sockets <http://lessons.livecode.com/m/4071/l/12924-how-to-communicate-with-other-applications-using-sockets> but that doesn’t even mention secure sockets.

I’ve also found: 
http://runtime-revolution.278305.n4.nabble.com/documentation-for-open-socket-using-certificate-and-key-sccept-only-ssl-td4691771.html <http://runtime-revolution.278305.n4.nabble.com/documentation-for-open-socket-using-certificate-and-key-sccept-only-ssl-td4691771.html>

In which Mark Waddingham replies, but there is no real answer

and 

http://use-livecode.runrev.narkive.com/iBKN5kKd/secure-sockets <http://use-livecode.runrev.narkive.com/iBKN5kKd/secure-sockets>

In which Björnke von Gierke asks numerous questions, but gives up when no answers come.

My own post on the forums (http://forums.livecode.com/viewtopic.php?f=11&t=26225 <http://forums.livecode.com/viewtopic.php?f=11&t=26225>) with sample files also has no responses.

I’ll file a bug report if needed, but I’m hoping I’m just missing something “simple” here. With sockets now on mobile, being able to communicate securely is a must have. 

Thanks in advance,

Steve MacLean




More information about the use-livecode mailing list