LC 8 (DP4) widgets

Glen Bojsza gbojsza at gmail.com
Wed Sep 23 18:32:34 EDT 2015


Yes because this issue just occurred again.

I start a new stack
 set the backcolor of the stack to white (save and check in the simulator
and on the iPad...looks fine)

add a widget (sgvpath one)

Error messages start again.

On Wed, Sep 23, 2015 at 6:18 PM, Ali Lloyd <ali.lloyd at livecode.com> wrote:

> Hmm, I think it might have been a problem with the interaction between
> widgets and named colors - I will do some investigation of that tomorrow as
> it may be a general issue.
>
> On Wed, Sep 23, 2015 at 6:39 PM Glen Bojsza <gbojsza at gmail.com> wrote:
>
> > I did mean the card or stack background and that is why the error seems
> > confusing.
> >
> > Here is what I did in the message box
> >
> > set the backcolor of stack t1 to white
> >
> > I deleted the stack and started fresh and it seemed to solve the
> issue...so
> > everything is fine now.
> >
> > Thanks for the follow up.
> >
> > On Wed, Sep 23, 2015 at 1:13 PM, Scott Rossi <scott at tactilemedia.com>
> > wrote:
> >
> > > I thought you meant the card (or stack) background, but it sounds like
> > > maybe you mean a widget background? If that's the case, you'd need to
> > look
> > > at the specific widget and determine what properties can be set for it.
> > > Not sure what that error you're seeing is coming from.
> > >
> > > Regards,
> > >
> > > Scott Rossi
> > > Creative Director
> > > Tactile Media, UX/UI Design
> > >
> > >
> > >
> > >
> > > On 9/23/15, 9:09 AM, "use-livecode on behalf of Glen Bojsza"
> > > <use-livecode-bounces at lists.runrev.com on behalf of gbojsza at gmail.com>
> > > wrote:
> > >
> > > >Hi Scott,
> > > >
> > > >I did this but an error is constantly generated.
> > > >
> > > >stack "com.livecode.pi.color.behavior":execution error at line 17
> > > >(extension:error occurred with domain) near "runtime", char 1
> > > >
> > > >here is the offending line
> > > >
> > > > *set* the swatchcolor of control 1 of me to item 1 to 3 of tValue
> > > >So for now I will just use a white filled graphic.
> > > >
> > > >Not sure if you have seen a similar error?
> > > >
> > > >
> > > >On Wed, Sep 23, 2015 at 10:58 AM, Scott Rossi <scott at tactilemedia.com
> >
> > > >wrote:
> > > >
> > > >> That's the default no-color appearance on iOS.  If you want things
> to
> > be
> > > >> white, you can set the card or stack backColor to white.
> > > >>
> > > >> Regards,
> > > >>
> > > >> Scott Rossi
> > > >> Creative Director
> > > >> Tactile Media, UX/UI Design
> > > >>
> > > >>
> > > >>
> > > >>
> > > >> On 9/23/15, 7:28 AM, "use-livecode on behalf of Glen Bojsza"
> > > >> <use-livecode-bounces at lists.runrev.com on behalf of
> gbojsza at gmail.com
> > >
> > > >> wrote:
> > > >>
> > > >> >I also wonder why the background in LC seems white but on the
> > simulator
> > > >> >and
> > > >> >iPad itself the background is grey?
> > > >>
> > > >>
> > > >>
> > > >> _______________________________________________
> > > >> use-livecode mailing list
> > > >> use-livecode at lists.runrev.com
> > > >> Please visit this url to subscribe, unsubscribe and manage your
> > > >> subscription preferences:
> > > >> http://lists.runrev.com/mailman/listinfo/use-livecode
> > > >>
> > > >_______________________________________________
> > > >use-livecode mailing list
> > > >use-livecode at lists.runrev.com
> > > >Please visit this url to subscribe, unsubscribe and manage your
> > > >subscription preferences:
> > > >http://lists.runrev.com/mailman/listinfo/use-livecode
> > >
> > >
> > >
> > > _______________________________________________
> > > use-livecode mailing list
> > > use-livecode at lists.runrev.com
> > > Please visit this url to subscribe, unsubscribe and manage your
> > > subscription preferences:
> > > http://lists.runrev.com/mailman/listinfo/use-livecode
> > >
> > _______________________________________________
> > use-livecode mailing list
> > use-livecode at lists.runrev.com
> > Please visit this url to subscribe, unsubscribe and manage your
> > subscription preferences:
> > http://lists.runrev.com/mailman/listinfo/use-livecode
> >
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>



More information about the Use-livecode mailing list