list field not getting arrowkey msg

Mike Bonner bonnmike at gmail.com
Tue Jul 21 18:47:08 CEST 2015


Hey, in fact, the easiest test I can find to prove this is..
put a mouseup handler in a field with ONLY select empty.
Then try it.  Boom, no arrow keys.

On Tue, Jul 21, 2015 at 10:44 AM, Mike Bonner <bonnmike at gmail.com> wrote:

> What I mean is.. When I use tab to change focus between fields, the arrow
> keys do nothing in the field I tabbed into.
> When I click and select a line in the field, then the arrow keys work.  In
> the former, the focusedobject correctly shows the field in question, but
> has no selectedchunk.  In the latter, the focus is correct, but the
> seletedchunk reflects the line clicked.
>
> Remove the "select empty" from the top of your handler and it should
> work.  Just tried it here.
>
> On Tue, Jul 21, 2015 at 10:26 AM, Peter M. Brigham <pmbrig at gmail.com>
> wrote:
>
>> That's my next step.
>>
>> -- Peter
>>
>> Peter M. Brigham
>> pmbrig at gmail.com
>> http://home.comcast.net/~pmbrig
>>
>> On Jul 21, 2015, at 11:26 AM, Dr. Hawkins wrote:
>>
>> > Foolish question, but have you tried creating a new field from scratch,
>> > pasting the script, and seeing if that works?
>> >
>> > I've had to do that a couple for times when some exotic and
>> non-displayed
>> > property or another got set.
>> >
>> > --
>> > Dr. Richard E. Hawkins, Esq.
>> > (702) 508-8462
>> > _______________________________________________
>> > use-livecode mailing list
>> > use-livecode at lists.runrev.com
>> > Please visit this url to subscribe, unsubscribe and manage your
>> subscription preferences:
>> > http://lists.runrev.com/mailman/listinfo/use-livecode
>>
>>
>> _______________________________________________
>> use-livecode mailing list
>> use-livecode at lists.runrev.com
>> Please visit this url to subscribe, unsubscribe and manage your
>> subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>
>
>


More information about the use-livecode mailing list