Datagrid Form

Peter Haworth pete at lcsql.com
Fri Jul 3 21:04:00 CEST 2015


Can't believe I haven't used a datagrid form before but trying one for the
first time this morning, following the instructions in the dg manual.

Set the dg type to "form"
Edited the row template to include a couple of fields and a check box
Added a button that sets up an array keyed by the field/checkbox names with
some data in each key and sets the dgData of the dg
Edited the FillInData of the row behavior get the data and put it into the
fields/set the hilite of the checkbox
Clicked the button to populate the dg

Nothing.

Set a breakpoint at the start of the FillInData handler and tried again.

At the start of the handler, my fields and checkbox show up in the datagrid
with no data in them.  As each line is executed to put the data into them,
nothing shows in the datagrid.  Each line looks something like:

put pDataArray["Company"] into field "Company" of me

pDataArray has the correct values in each key

Continued stepping through and next comes the LayoutControl handler. I
haven't changed that yet.  Step through each line, nothing changes in the
datagrid.  After stepping over the end LayoutControl, my fields/checkbox
all disappear and no more code is executed.

LC 6.6.5, OSX 10.10




Pete
lcSQL Software <http://www.lcsql.com>
Home of lcStackBrowser <http://www.lcsql.com/lcstackbrowser.html> and
SQLiteAdmin <http://www.lcsql.com/sqliteadmin.html>


More information about the use-livecode mailing list