Fwd: Livecode unable to work with proxy servers?

David Beck david at rotundasoftware.com
Tue Feb 3 04:56:03 CET 2015


Hello,

We have a government client that has Websense Content Gateway, a linux
based web proxy, setup for their network. When they try to use our livecode
stand alone behind that proxy, our stand alone is unable to communicate
with our web servers. The standalone is built with LiveCode 6.7.1rc1.

Are there known problems with LiveCode 6.7.1 and proxy servers? Does 7.x
play any better with proxies?
Is there something we need to do in order to get this working right? Do we
need to set the HTTPProxy property?
Does anybody have any ideas on how we can help the client track down this
issue?

The support team at Websense declared the livecode standalone "unable" to
work with proxy servers, due to the issues outlined below. However I can't
believe this is right.

Thank you in advance for any help!

David Beck

> Hi Tim,
> I did lots of test on Volunteer Scheduler pro with proxy. This issue is
caused by this application doesn't send standard SSL traffic to WCG,
following is the data that this application has send to WCG:
> ------------------------------------------------------------------
> CONNECT v5.mspnetservices.com <http://v5.mspnetservices.com/>::443
HTTP/1.1
> Host: v5.mspnetservices.com <http://v5.mspnetservices.com/>::443
> Content-type: multipart/form-data;
boundary="_Part_5e8pxn7dpocjxwfhs7twqn2xl"
> --_Part_5e8pxn7dpocjxwfhs7twqn2xl
> Content-Disposition: form-data; name="request"
> Content-Type: application/octet-stream
> Content-transfer-encoding: binary
>
R$.50....<NULL34927><NULL34927><NULL34927><NULL34927><NULL34927><NULL34927>.sO-..LN.+N..K./.M,...ce```370024.......u....t...,."....&.&......^.Q.<NULL34927>....F<NULL34927><NULL34927><NULL34927>
> --_Part_5e8pxn7dpocjxwfhs7twqn2xl
> Content-Disposition: form-data; name="dontEncryptResponse"
> Content-Type: application/octet-stream
> Content-transfer-encoding: binary
> 1
> --_Part_5e8pxn7dpocjxwfhs7twqn2xl
> Content-Disposition: form-data; name="dontDecryptRequest"
> Content-Type: application/octet-stream
> Content-transfer-encoding: binary
> 1
> -_Part_5e8pxn7dpocjxwfhs7twqn2xl-
> -------------------------------------------------------------------------
> Above data has three problems:
> 1.CONNECT header has two colons before port 443.
> 2.CONNECT request has private data without Content-Length header.
> 3.Even after WCG tunnelled above data to remote server(
v5.mspnetservices.com <http://v5.mspnetservices.com/>), remote server
didn't send back any response.
> From test, I think this application can't work with any proxy(like
Websense, Bluecoat or other vendors), Customer should check above problems
with this application's vendor.
> Thanks
> Ze


More information about the use-livecode mailing list