mouse pointer hot spot is way off

Dar Scott dsc at swcp.com
Mon Aug 17 21:31:50 CEST 2015


Yay!  That’s it.  Second monitor with top above the main monitor with LiveCode window top above the same thing.  

This might be a bad fix for another bug, the one that blocks a stack from going higher than the tool bar.  

I know how it is about having work to get done and repeating little workarounds rather than reporting a bug.  

If you don’t report it, I’ll report it or add it to the other bug.  

Dar


> On Aug 17, 2015, at 10:17 AM, Devin Asay <devin_asay at byu.edu> wrote:
> 
> 
>> On Aug 15, 2015, at 8:37 AM, Dar Scott <dsc at swcp.com> wrote:
>> 
>> Hi, I’m an old-timer who has been away from the list for a while.
>> 
>> I’ve run into a problem and I think it is a LiveCode problem but it might be an OS X problem or some combination.  
>> 
>> I’m using 6.7.5.  
>> 
>> Very often the hot spot is off, usually about 50-100 pixels high, for one or more windows in the IDE.  I usually notice it in the editor where it is off by 3 lines.  Almost always it is just vertical.  
>> 
>> It also happens in my stacks.  
>> 
>> This only applies to content, not the title bar or the menu along the top.
>> 
>> I wasn’t able to find anything among the bugs.
>> 
>> It might have been coincidence but one time it didn’t go away until I rebooted.  I was on Mavericks but now am on Yosemite and still see it.  
>> 
>> Insight?  Anybody else seen this?  Or is this old news?
> 
> Hi Dar,
> 
> I have seen this and can reproduce it reliably. On a Mac, if you have two monitors (or more I suppose), and you open a script editor window, it initially opens on the same screen as your LiveCode IDE; on the "main screen” as determined by the OS. After that I typically move the script editor window to the second monitor. I find that if the top of the script editor window is higher than the tool bar on the main screen, I get this hot spot offset problem. Once I move the window downward on the second monitor it goes away. I ought to have reported it, but I’ve gotten to where I automatically just move the window down to avoid the problem. 
> 
> Does this seem to be the same thing you’re getting?
> 
> Devin
> 
> 
> 
> Devin Asay
> Office of Digital Humanities
> Brigham Young University
> 
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
> 




More information about the use-livecode mailing list