Odd behavior in Win8-I'm stuck fixing it, Help??

William Prothero prothero at earthednet.org
Tue Aug 4 01:22:19 CEST 2015


Paul:
Thanks for the hint. I do use the newer “from” syntax.
   export snapshot from rect  snapRect to image "mapSnap"

Thanks,
Bill

> On Jul 31, 2015, at 3:35 PM, Paul Hibbert <paul at livecode.org> wrote:
> 
> Bill,
> 
> I’ve just read the following explanation from RG relating to another snapshot problem and wondered if it also relates to your student’s problems…
> 
>> 
>> The "from" option renders the object into a new buffer set up just for the snapshot, while the older "of" syntax grabs the object's rect from the composite screen buffer.
>> 
>> LiveCode renders only the content region of a window but the window itself is rendered by the OS, so it has no choice but to obtain that image from the screen buffer.
>> 
>> -- 
>> Richard Gaskin
>> Fourth World Systems
>> Software Design and Development for the Desktop, Mobile, and the Web
>> ____________________________________________________________________
>> Ambassador at FourthWorld.com                http://www.FourthWorld.com
> 
> When I first read your post I wondered if the problem could be due to low grade or incompatible video cards in the affected machines, if that’s the case then the above explanation would make sense, to me at least.
> 
> So, the question is, does your "export snapshot" script use the “from” or “of” option?
> 
> If it’s the “of” option then switching to the “from” option may fix the problem your students are seeing.
> 
> Just a thought.
> 
> Paul
> 
> 
>> On Jul 16, 2015, at 14:07, William Prothero <prothero at earthednet.org> wrote:
>> 
>> Folks:
>> I have an application that is being used by a class of Earth Science students and get failure reports from two who use Windows 8. One lives in Australia and one lives in Japan. The app works fine on Macintosh. I’ve also tested it on my own installation of both Windows 8.1 and 7, 32 bit and 64 bit versions. I can’t get the reported pixellation of the map and screen. 
>> 
>> I’m wondering if it is something related to foreign installations. The symptom is extreme pixellation of images captured with the "export snapshot” command. I live in the US.
>> 
>> So, I wonder if somebody with Windows 8 would be willing to download the app and try it, and perhaps give me an idea of what might be going on. If it’s a bug in “snapshot”, it would be important to be reported and fixed. Otherwise, I’m pretty stuck on figuring out what is going on. 
>> 
>> Here are links:
>> Windows zip file of the app:  <https://www.dropbox.com/s/lsn087vrhstxvg4/PT_Explorer-Windows.zip?dl=0>
>> Pixellated Image sent by a student <https://www.dropbox.com/s/m2frv9i0dg7mxtp/Explorer%20in%20Windows%208.1.pdf?dl=0>
>> 
>> Thanks for any help or feedback you can give me. 
>> 
>> Regards,
>> Bill
>> 
>> 
>> William A. Prothero
>> http://es.earthednet.org/
>> 
>> _______________________________________________
>> use-livecode mailing list
>> use-livecode at lists.runrev.com
>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
> 
> Regards,
> 
> Paul Hibbert
> paul at livecode.org
> 
> 
> 
> 
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode



More information about the use-livecode mailing list