LiveCode 7.0.0-DP-5 Linux

Richmond richmondmathewson at gmail.com
Wed May 28 14:20:03 EDT 2014


On 28/05/14 18:22, Fraser Gordon wrote:
> On 28 May 2014, at 15:01, Richard Gaskin <ambassador at fourthworld.com> wrote:
>> The "You Only" requirement when installing under a non-admin account seems an unnecessary drag.  When I install any .deb file I'm prompted to enter an admin password, but the LC installer only prompts for the current account and requires that the account be on the sudoers list.
>>
>> Fraser, can this be changed?
> All LiveCode does during the install is to re-launch itself using gksu:
>
> gksu --preserve-env /path/to/installer.x86 $MAGIC_INSTALLER_OPTIONS
>
> The installer relies on the gksu programme to do the authentication and authorisation magic; it can't really influence how it does that job. Normally, gksu follows whatever rules the /etc/sudoers file specifies.
>
> One problem is that some versions of Ubuntu and other distros no longer include gksu by default. The Ubuntu recommendation (somewhat strangely) is to get people to use "sudo" on the command line instead; hardly the most user-friendly way to run the installer. An alternative is to use pkexec, which should provide the same features as gksu, but (at least last time I tried) wasn't a drop-in replacement so things stopped working.
>
> Why does everyone make it so difficult to get admin privileges? ;)
>
> Regards,
> Fraser
>

Further "entertainment":

I successfully installed the 7.0.0 DP 5 'second attempt' with the "All 
Users" option.

When I launched it [Livecode 7.0.0 dp 5] it offered me the chance to UPGRADE
to version 6.7.0 dp 4.

Lovely :)

Richmond.




More information about the Use-livecode mailing list