iOS Home Button Shutdown not working!

Rick Harrison harrison at all-auctions.com
Thu May 8 17:30:48 EDT 2014


Hi Chris, Jacque, and Stephen,

I built a test stack just to test the
shutdown handler.  I used the
write to file to see if it created
a file and then read the data
back in to see if it worked.

The shutdown does not
appear to be working at all.

If I have a button send the message
to the shutdown handler the
code executes - writes the file, and
reads the file correctly.

I’m reluctant to move to a newer
version of LC than 6.5.2 because
the newer version I tried - LC 6.1.1
made my animations run 4 times
slower.  They looked terrible!

Has the speed/performance improved
adequately in LC 6.6.2?

Thanks,

Rick


On May 8, 2014, at 3:05 PM, J. Landman Gay <jacque at hyperactivesw.com> wrote:

> On May 8, 2014, at 9:20 AM, Rick Harrison <harrison at all-auctions.com> wrote:
>> I’m using LC version 6.5.2 and tested in both the simulator and on the device.
>> I used the “put” statement at the beginning of the handler but do not see my
>> message displayed when I press the “Home button”.  I also tried using an
>> answer statement to do the same thing.  No message appears for me.
> 
> The answer dialog should have worked. The only other thing I can think of is that there are other shutdown handlers somewhere in the message path that are blocking the one you're trying to test. Try searching all the scripts for an extra one.
> 
> -- 
> Jacqueline Landman Gay         |     jacque at hyperactivesw.com
> HyperActive Software           |     http://www.hyperactivesw.com
> 
> 
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode






More information about the Use-livecode mailing list