Checkboxes

Richmond richmondmathewson at gmail.com
Tue May 6 07:06:05 EDT 2014


On 06/05/14 00:24, Dar Scott wrote:
> A kid recently made a fireball object.  He called it a ‘part' so he could change from graphic to image.  (I didn’t explain behavior and me, but this will have to come up.)
>
> Dar
>
>

'part', 'bit', 'component', 'control', 'thingy', 'object' . . . what I 
call something is not going to do much good unless:

1. I adhere to a standard naming convention,

or

2. I make it contextually clear what I mean.

On Day #1 I would have thought it would not be a bad idea to have "the 
naming of parts"

[ http://www.solearabiantree.net/namingofparts/namingofparts.html ]

to avoid confusion at a later date . . .

. . . you know, that sort of wiggly thingy that makes the whim-wham go 
all woozhly . . .

private codes are all very fine and even, sometimes, fun; but not much 
good in the
wider world.

So; why not stick with OBJECT ?

This is certainly better than CONTROL as not all objects contain scripts 
to control other things
or precipitate action. And, better than PART as that implies the OBJECT 
is somehow a dependent
component of a greater something, and it may not be.

Richmond.




More information about the Use-livecode mailing list