please help!!

larry at significantplanet.org larry at significantplanet.org
Sat Jun 7 23:39:34 EDT 2014


Thank you Randy, but that's not the case here.
After I got your email, I triple checked.  It's something else going on.

----- Original Message ----- 
From: "Randy Hengst" <iowahengst at mac.com>
To: "How to use LiveCode" <use-livecode at lists.runrev.com>
Sent: Saturday, June 07, 2014 9:21 PM
Subject: Re: please help!!


> When I've had similar problems I had multiple buttons with the same name.
>
>
>> On Jun 7, 2014, at 9:41 PM, larry at significantplanet.org wrote:
>>
>> I am using 6.1.1 (rc 4) on XP
>>
>> I have spent HOURS trying to do something that seems fairly simple.
>>
>> I have a column of buttons labeled "tile11", "tile12", etc
>>
>> After I label the buttons, they are all alpha-numeric characters except 
>> for one being labeled "?"
>>
>> Then I call up the following command:
>>
>> on doOpaque
>>
>> put 0 into x
>>
>> repeat rowNum times
>>
>> put x + 1 into x
>>
>> put ("tile1" & x) into thisButton
>>
>> if the label of button thisButton = "?" then
>>
>> set the opaque of button thisButton to true
>>
>> else
>>
>> set the opaque of button thisButton to false
>>
>> end if
>>
>> end repeat
>>
>> end doOpaque
>>
>>
>>
>> If I debug and step through it, it always seems to work.  However if I 
>> just run it, it invariably sets the opaque of the "?" button to false and 
>> some other button (NOT "?") to true.
>>
>> I'm really going crazy with this and would appreciate it if anyone knows 
>> why this is happening.
>>
>> Thanks in advance, Larry
>> _______________________________________________
>> use-livecode mailing list
>> use-livecode at lists.runrev.com
>> Please visit this url to subscribe, unsubscribe and manage your 
>> subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
>
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your 
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode 





More information about the Use-livecode mailing list