Inactive Menu Bar?

Peter Haworth pete at lcsql.com
Wed Apr 2 20:30:25 CEST 2014


Where are your menPick handlers?  As I recall they have to be in the
menubar group not on each button that represents a menu.  Doesn't fit your
problem exactly but maybe contributing.

Pete
lcSQL Software <http://www.lcsql.com>
Home of lcStackBrowser <http://www.lcsql.com/lcstackbrowser.html> and
SQLiteAdmin <http://www.lcsql.com/sqliteadmin.html>


On Wed, Apr 2, 2014 at 9:55 AM, Graham Samuel <livfoss at mac.com> wrote:

> This is an odd one. I'm developing a desktop app with a menu bar (Mac) all
> set up and fully working in early development cycles. When running under
> the IDE, one click on the mainstack which owns the menu replaces the IDE's
> own menu with mine, as expected, and that menu works as normal. Then I pick
> one of my menu options, a script gets run and something goes wrong - the
> IDE menu no longer gets replaced and my own menu doesn't show. The menu
> still exists, and I can send "menuPick" messages from the Message Box and
> get them to work, but I just can't see the menu bar. Mostly I'm using LC
> 6.5.2 for this, but the same problem shows on 6.6.1 rc1.
>
> I made a standalone, and the menu bar appears, with nothing dimmed, and
> the dropdowns animate, but none of the menu items do anything, i.e. no
> "menuPick" messages are being sent. Other bits of the program are working
> and respond to mouse events etc.
>
> Of course it's a bug of my own making, but what's going on? What the heck
> did I do wrong?
>
> TIA for any suggestions
>
> Graham
>
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>


More information about the use-livecode mailing list