repeat . . . delimit by

Dr. Hawkins dochawk at gmail.com
Sat Sep 14 19:10:32 EDT 2013


While we're asking for modest syntax changes . . .

Being able to state DELIMIT BY in a REPEAT, and having it stick (as opposed
to using the current value of the itemdelimiter) would be a huge help.

It would avoid ugliness like

set the itemDel to vtab
repeat for each item theDat in theData
set the itemDel to tab
do something
set the itemDel to vtab
end repeat

While missing the last reset to vtab is a programming error, mu code is
kind of
littered with these (constant db accesses)

code would be much easier to follow (and maintain) with

repeat for each item theDat in theData DELIMTED BY vtab
do something
end repeat

And while I'm at it, it's been mentioned before, but a Fortran-style
optional tying of the end repeat to the repeat with a constant would be
really helpful (same for switch, and so forth)

[Fortran 90+, not FORTRAN IV!!!!]
-- 
Dr. Richard E. Hawkins, Esq.
(702) 508-8462



More information about the use-livecode mailing list