https, MacOS and Certificates

J. Landman Gay jacque at hyperactivesw.com
Thu Nov 7 21:10:03 EST 2013


If/when you find out more details, could you let us know? I may have to 
deal with this too.

On 11/7/13 6:04 PM, Timothy Bleiler wrote:
> It's tricky. One that works is running 10.7, one used to work and now
> doesn't is running 10.7. One worked under 10.5 and failed when
> upgraded to 10.7. I only just tracked it down to this issue earlier
> today and haven't gotten any details back from other users yet.
>
> Tim
>
> On Nov 7, 2013, at 4:28 PM, "J. Landman Gay"
> <jacque at hyperactivesw.com> wrote:
>
>> On 11/7/13 9:25 AM, Timothy Bleiler wrote:
>>> I've been getting some simple information back from an active
>>> server page using this script
>>>
>>> Put "https://MyServer/MyActiveServerPage.aspx?uID=1001" into
>>> tURLString Get URL tURLString
>>>
>>> This is generating an error with certificates on some Macs but
>>> not all. On the Macs where the problem occurs, the URL can be
>>> accessed through the web browser but NOT through Livecode. This
>>> makes me suspect that the problem is not just with the
>>> certificates but with how liveCode is using the keychain system.
>>
>> LiveCode tries to find the default installed certificate in the OS
>> and uses that when sending https requests. There's a known failure
>> to find the certificate on Mac OS 10.6. Are the Macs that fail
>> running that version of the OS?
>>
>> -- Jacqueline Landman Gay         |     jacque at hyperactivesw.com
>> HyperActive Software           |     http://www.hyperactivesw.com
>>



-- 
Jacqueline Landman Gay         |     jacque at hyperactivesw.com
HyperActive Software           |     http://www.hyperactivesw.com




More information about the Use-livecode mailing list