Livecode iOS Externals and XCode 4.6

Monte Goulding monte at sweattechnologies.com
Thu Mar 21 23:25:18 EDT 2013


On 22/03/2013, at 1:57 PM, charles at techstrategies.com.au wrote:

> I can set the deployment target to lower versions of iOS, just can't use the older SDKs.  When I have a device connected to XCode, it shows the device multiple times under schemes - one for each SDK that I have installed in XCode.  Only when using the scheme for the device that is using the 6.1 SDK does it actually link correctly in LiveCode - even though it builds successfully in XCode.
> 
> Not really an issue though, as I believe Apple will only allow submissions with at least the 6.0 SDK now, and the deployment targets can still be set lower.

You can build against the older SDKs but the standalone builder would have been looking for a build against the most recent SDK you have installed and linked to LiveCode in your prefs. I build my externals against lots of SDKs so I can support users with older Xcode/LiveCode combinations.

--
M E R Goulding 
Software development services
Bespoke application development for vertical markets

mergExt - There's an external for that!




More information about the Use-livecode mailing list