Sending mouseUp

Peter Haworth pete at lcsql.com
Wed Mar 20 16:07:51 CDT 2013


Yep, that's my experience too.  Don't remember all the combinations I tried
but here's the one that really surprised.

1. Ran LC and opened my stack from within it.  Got the mouseUp problem.
2. Closed the stack and opened it again from within LC.  All worked OK.
3. Closed the stack and removed it from memory then opened it from within
LC.  All worked OK!

Step 3 is what really surprised me, I thought that should have had the same
result as step 1.

It's as if preOpenCard doesn't quite work right the very first time it is
executed in any stack in a run of LC, but ever after it's OK.


On Wed, Mar 20, 2013 at 1:49 PM, <dunbarx at aol.com> wrote:

> There is no such card (yet); the card just does not exist. However, also
> in a new session, if you open another stack, and then open the test stack
> from the finder, all is well.  So "preOpenCard" is invoked REALLY early,
> but it seems to matter when and how it is invoked as well.
>



Pete
lcSQL Software <http://www.lcsql.com>


More information about the use-livecode mailing list